Technical display mode compute issue

Yesterday I’ve been playing with Holomark which brought to my atention I’m having some sort of issue with computing technical display modes. First of all - it takes like forever. Secondly CPU load on all cores goes to 100% . Here’s the Holomark result:

*GPU scores: 10420
GPU_01 - 137.00 fps - Cube 4 tests
GPU_02 - 29.70 fps - UDT Shape
GPU_03 - 49.50 fps - Wireframe
GPU_04 - 33.30 fps - Shaded
GPU_05 - 18.80 fps - Rendered
GPU_06 - 15.90 fps - Block Rendered
GPU_07 - 14 units Nurbs @ 5 fps in Wireframe
GPU_08 - 8 units Nurbs @ 5 fps in Shaded
GPU_09 - 18 units Nurbs @ 5 fps in RenderSpeed
GPU_10 - 56.80 fps - RenderMesh Render
GPU_11 - 56.80 fps - RenderMesh RenderSpeed
GPU_12 - 44.80 fps - JoinedMesh Render
GPU_13 - 54.10 fps - JoinedMesh RenderSpeed
GPU_14 - 3 units mesh @ 15 fps in Shaded
GPU_15 - 3 units mesh @ 15 fps in Render
GPU_16 - 6 units mesh @ 15 fps in RenderSpeed
GPU_17 - 33.00 fps - mesh in Rendered Studio
GPU_18 - 7.20 fps - Nurbs in Rendered Studio
GPU_19 - 18.00 fps - Block Illustration
GPU_20 - 57.10 fps - 2D single
GPU_21 - 6.30 fps - 2D massive (20x)

CPU scores: 2663
CPU_01 - 13.82 sec - Booleans and Contours
CPU_02 - 1.76 sec - Twist and Taper (UDT)
CPU_03 - 6.18 sec - Meshing Mini
CPU_04 - 0.03 sec - Extract Render Mesh
CPU_05 - 0.05 sec - Join Render Mesh
CPU_06 - 15.74 sec - Reduce Mesh
CPU_07 - 146.12 sec - Calculating Technical display

CPU_08 - 4.03 sec - Making Silhouettes

LENOVO
Lenovo IdeaPad Y580
NVIDIA GeForce GTX 660M - 2048.0 MB
DriverVersion: 9.18.13.3523
Intel(R) HD Graphics 4000 - 2112.0 MB
DriverVersion: 8.15.10.2598

Intel(R) Core™ i7-3610QM CPU @ 2.30GHz
NumberOfCores: 4 NumberOfLogicalProcessors: 8
MaxClockSpeed: 2.3 GHz

TotalPhysicalMemory: 8.0 GB

Microsoft Windows 7 Home Premium

  • Service Pack 1 - 64-bit*

Rhino 5 sr 8 64 bit

Tried disabling AA, anisotropic etc , reverting to built-in card instead of GTX 660M , but as I suspected it didn’t help. It is CPU that shows this crazy load not GPU.

Any ideas what is wrong and can be done about it?

Sorry you have had no replies.
@jeff. Any ideas about this?

Thx Margaret - would be awesome to get some insight what may be the cause of it (and possibly howto fix it). I tried reinstalling the Rhino (with cleaning Rhino registry entries I could find) but that didn’t help either.

I guess I’m not seeing a problem or bug here. What exactly is the bug? From what I can tell, this is a misunderstanding of what actually is going on, and/or misconceived expectations.

The technical data is computed by the CPU and drawn by the GPU…and those computations are attempted to get done across multiple CPU cores to help speed up the process. It is not graphical information being computed (i.e. not pixels), it is geometry, intersections, silhouette information, etc…That information is then used to represent something graphically on the screen via the GPU.

That is why Jorgen lists this specific benchmark under the CPU section, not the GPU…

So from the sounds of it, things are working exactly the way they’re supposed to, they’re just not working the way you seem to expect them to. I will say though, that 146 seconds does seem quite long for this particular test. However, I will also point out that the Intel i7-3610QM scores dead last in the CPU Benchmark tests when compared to the Top 10 commonly used CPUs.

-J

Other i7s are in the range of 2 secs for the CPU_07 test. On the Holomark results page there is an old Pentium that the scores for the rest of the CPU tests are 3 times slower than the above, and its CPU_07 is only 7 seconds!

Seems like there is something wrong somewhere to me.

I have no idea what causes this, but I just want to jump in and say that 4 seconds is what I would the expected on that test for that system.

I wonder if the IntelHD chip/driver could cause some trouble.
I don’t remember exactly how, but on dual graphic card systems you can choose that Rhino shall be handled by the 660M. I wonder if it was in the nVidia drivers, I helped a customer doing so a year ago.

Good luck

Like I said, I too agree that 146 seconds seems quite long… However, as you just pointed out, other CPU test scores seem to be on the mark…which means there is something different about this configuration, not Rhino, not Holomark, and not the GPU.

I don’t know why the same test would completely bog down on a specific configuration…it’s the same code running and executing in exactly the same manner. If Rhino actually special cased CPUs then I could see potential differences, but it doesn’t, so I’m at a loss.

The only thing that comes to mind is this… Rhino uses OpenCL to spread computations out across the multiple CPU cores, so it’s possible that the OpenCL implementation on this configuration is either somehow limited and/or poorly implemented…I just don’t have enough information at the moment to conclude anything.

-J

Also, just because other results from i7’s are good doesn’t really mean anything. It depends on which i7 you’re talking about… There are quite a few different i7’s out there, and the specific one in this case appears to be on the lower end.

See here: http://www.cpubenchmark.net/cpu.php?cpu=Intel+Core+i7-3610QM+%40+2.30GHz

@jeff : but as has been pointed out even machines with much worse processors get better results, much better. So it is clearly something wrong with my setup - it’s not a matter of misdirected expectations. Heck, I wouldn’t complain if I hadn’t made a test on a low end machine in the workshop I work in.
Oh , and btw - the 146 second result does not mean the test has been completed successfuly. The test simply timed out. In short - I can’t get those tech views on an even slightly more complex scenes. On a very simple ones (couple of spheres) it takes a short but noticeable moment (on low end machine it is instant). When it gets computed for teh first time I can switch on and off without delays.
Had some hopes about OpenCl - reinstalled it. Sadly that did not help. Tried on both internal Intel HD4000 and GTX660M. Then did OpenCl benchmark (with Compu Bench CL) for the CPU and both GPU’s - each benchmark went ok.
So I’m kinda stuck - the only thing that comes to my mind is reinstalling the whole OS and checking out a clean install. But as you may imagine I would prefer to avoid that.
I understand that it must be something specific with this configuration - possibly down to Windows and maybe some messed registry entries.
On the laptop I’m running a Windows 7 Home PL .
If there’s some data I could provide so we could try to nail this issue down let me know - I’ll do my best to get it.

This could be a driver issue as well, I would recommend getting this product:

http://www.raxco.com/home/products/perfectupdater

They seem to do a good job with this product, I was getting some blue screens earlier in the week, thought I might have to wipe the system, but as a last effort I ran this and updated all the drivers on the system and the problem went away. You are going to find there are several drivers you had no idea needed to be updated. It is worth a look.

HTH,
Don

@przemas You also may want to check and see if there are any BIOS updates for you PC.

HTH,
Don

Have you double checked that the Intel card isn’t interfering with the geforce?

I would recommend buying a separate HDD and do a reinstall to that one, instead of formatting the one you have, just in case. It’s a cheap insurance, and if you don’t have a SSD then you can use the opportunity to get one.

Guys, I don’t think this is going to be a driver issue. Technical display does not use the GPU for its calculations. Trying different drivers or different cards is probably not going to yield any different results.

Przemas, I apologize, I did not realize that the test was not completing…I thought it was just taking a long time but eventually finished. What happens if you enter into Technical mode on a simple model (i.e. a couple of boxes, spheres and torii)?

I’m starting to wonder if it’s a tolerance thing…When computing all of the intersection, really tight tolerance could impact the results. However, those are document settings and/or template settings. Have you modified any of your templates for tighter tolerances?

Jorgen, does Holomark set tolerances? If not it probably should because it can really skew results if everyone is not using the same EXACT settings everywhere.

-J

Hi Jeff, yes Holomark sets the tolerance. It uses an included, empty file as template, then inserts the mini file into that. (To control settings and avoid unwanted tampering with the mini file) I tried to eliminate all custom settings any user could have. The template uses Millimeter units and 0.01 as tolerance:

Due to unfortunate accident that forced me to reinstall OS I had a chance to test it on vanilla Win 7 install. The bad news - I can’t validate my license (contacted local reseller for help). The good news - technical / pen display modes work as they should :slight_smile: .

Hello @Przemas , Did you ever figure out what was causing your Technical view slowness. I’m having similar 140second wait times in the Holomark2 released this week. I have a Quadro6000 and an i7-3770 (4 x Cores/8x Threads). All 8x Threads go flatout for about 140seconds, whilst other guys with much slower CPU’s are posting times of 1.5seconds.
The rest of the compute times seem in spec with what the cpu should do, except for the twist and taper section where I am also getting times about 40x longer than much slower PCs. Hoping you found the missing link on your system.
I haven’t been using Technical views in Rh5 because of the long calculation time. I thought everyone had the same issues, but it seems it is just me, (And perhaps you too) Michael VS

Sadly I haven't figured out what caused the problem. The issue went away after I reinstalled the system - which I was forced to do at that time anyway.

I don’t think this is of any help, but this has happened to me once, and one time only… Maybe Rhino was checking the internet for updates, and maybe it was downloading in the background. I don’t know, but it took 25 seconds, and the rest of the test went on as usual.

Hello @Holo , I have been repeatedly getting times of 140sec - 160sec for the Technical View Mode portion of the test.
I’ve tried many things sofar and the only change which actually made an impact was to switch off Hyperthreading in the bios. My times are still very slow to most peoples 1.5sec, but it has dropped down to 85sec now with HT off. So now just the 4x Cores, and 4x Threads.
Switching off HT had no negative effects on any of the other Holomark2 tests and in fact some of them are slightly faster with HT off. Michael VS (i7-3770)