T-Splines to Rhino(Nurbs) conversion issues

Hi!
I am currently having the following issue:
When I convert a file from a T -splines to a Rhino NURBS surface I get too much CV counts for every single surface. If I compare my converted surface with my colleague it has twice as much CV. We tried to go trough all of our rhino and T spline settings but they seems to be the same. I have noticed that because the file size I produce is very big compared to my colleague’s one. I just wanted to know what causes this. Why my file has twice the CV counts for every single NURBS surface that I convert from T splines. I am attaching 2 images - One is from mine computer and the other one is from my collegue. You could clearly see how my isocurves are twice and the CV count is also way higher. I have tried looking for this issue but I could not resolve it. Any help is appreciated. Thank you in advance.


This is from my computer - this produces very big . STP file and the CV count is big

This is from my collegue’s computer - smaller file size .STP and way less CV count.

The T-Splines models might have different display settings, this is why the CV count is different.
Go to top menu T-Splines > Options > Display > Smooth Objects Speed and you can find Compatible, Fast and Fastest option.
You need to know that the only one that will give you the best continuity is the Compatible option, other modes are just to speed up the modeling process.

Both computers are set to Compatible.

You are saying that in both computers with the same version of T-Splines and starting from the same model in compatible mode when you convert the model to Nurbs you obtain different results?
If this is the case, I cannot reproduce it. The Model you showed with less CVs looks as a typical case of a Fast mode model converted.

I think you, guys, got it wrong. The “Fastest” produces less points when converted, as I remember.

Yes, fastest gives less points, but although it can look cleaner it is not as continuous as compatible mode. The strange thing here is that they apparently obtain different results from the same process.

I found something else, take a look at this object properties settings.
Compare the Star Smoothness of both models? May be you have different settings there, if both have Use Global they should convert the same I think.

Hi!
It was my mistake. My colleague Smooth Objects Speed was set to FASTEST option and mine was set to COMPATIBLE. I set mine also to FASTEST and this produces the same results for both computers now. Thank you very much for the help and sorry I gave you wrong information about the compatible modes. Again Thank you very much. My issue is resolved.

Best Wishes,
Plamen Drenski

1 Like