Switching materials between "plugin" and Rhino basic not possible at Rhino 6

unhandled

#1

Hi,

at Rhino 5 I can assign materials per Vray render plugin and go to the object material properties and disable “plugin”. Than I can edit basic material properties, so that my Vray material looks good at Enscape too, and switch back to “plugin”. So, I can render my scene per Vray or Enscape, both are good looking.

At Rhino 6, if I disable the “plugin” flag option, than the flag option is removed from the UI and I can’t switch back to “plugin”. Please bring the option back and allow to use the old double way.

Attached an example - here I assigned a red plastic per Vray, but I can change the color at the basic Rhino material options. This example makes no sense, but for example useful is to add an emissive color so that Vray emitters are emitters at Enscape too. Also the reflective parameters are not right set by the Vray plugin and so the correct look can be adjusted.

-Micha


#2

A second problem: if I disabled “plugin” at the object material properties, than there seems to be no way to assign the Vray material in plugin mode again. Also if I assign the material from the Vray material browser again, the “plugin” feature will not come back.


(Nathan 'jesterKing' Letwory) #4

I don’t see such a plugin checkbox. Is this something the VRay plugin adds?


#5

Maybe you need to switch to a render plugin before. Did you check it at Rhino 5?


(Nathan 'jesterKing' Letwory) #6

I checked with Brazil enabled in v6, no plugin checkbox for object material in object properties dialog.


(Andrew le Bihan) #7

Micha

I can see from your image that there is a check-box marked “Plug-in” on the object properties page. This appears after you uncheck “Plug-in” from the plug-in version of the page, for a plug-in material that doesn’t support the RDK.

I think the reason it doesn’t work for you at the moment is that there is no VRay in V6 with which to re-assign the material.

  • Andy

#10

Since a few days a Vray for Rhino 6 is available as nightly build. Do you mean it could be a bug that I can’t switch back to the plugin mode?


(Andrew le Bihan) #11

Yes, it could be


#12

How could fix it? Should I ask the Chaosgroup?