Switching from layout to views is not working

Hello. I am trying to Use Rhino in a more professional manner and build a layout.
When I try to switch from the layout back to the views I get just the view split without the views.
To recreate double click the layout “pir 1”

חיפוי פירים גג.3dm (10.6 MB) חיפוי פירים.gh (13.7 KB)

Hi -

I’m confused about that step to recreate the issue:

  • When I open that file here, the pir 1 layout is open (and zoomed waaaay out).
  • To get to the model space, I single click on any of the 4 model tabs.
  • Why is there a Grasshopper file attached?

At any rate, from that picture, it looks like the views are not getting updated. Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Hello
System info:
Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Commercial, build 2021-03-19
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 SUPER (NVidia) Memory: 8GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-19-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: (null)
Render version: 4.6
Shading Language: (null)
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: n/a
Z-Buffer depth: 24 bits
Maximum Viewport size: n/a
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I attached the Gh file because Maybe it caused the issue

Hi -

This part tells us that your GPU drivers are not correctly installed. A Windows update might have caused that at some point in the past. Please reinstall the latest drivers for the GeForce RTX.
-wim

Thanks Wim. Seems to work.
Have a good day