Sweep2 Surface not following curves

In my streetscape project I have been using Sweep2 to create surfaces for somewhat complex roads. I keep running into a problem where the surface that is created by the Sweep2 command doesn’t follow the curves accurately. I inserted an image below.

Here are my Sweep2 settings:
Sweep2 settings

I am using the Large Objects: Feet, Feet & Inches Template.
Absolute Tolerance: 0.01
Angle Tolerance: 1.0

I don’t remember running into this problem in earlier versions of Rhino. Any help to get a cleaner surface edge would be great!


Hi Miles- please check the DocumentProperties > Mesh page and set s finer display mesh of needed. See also -


It’s just a mesh setting that you can at any given moment, as @pascal mentioned.

Apart from that, this particular surface will be much more accurate and simple if you use the “Do not change cross sections” option. Also, try if turning off the “Refit rails” option will produce simpler output. Usually it does when your both rails are the same degree and number of control points.

Awesome, thank you guys