Sweep function and pipe functions aren't working right in RHINO 6


I am using the Rhino 6 ( Version 6 SR16 (6.16.19190.7001, 7/9/2019)) and out of any reason the sweep and pipe functions isn’t working right. I want to extrude a circle along curves, but out of any reasons it is not working. I also tried it with the sweep function, same result. I select the curves and cross section, but nothing is happening. Is this a bug? or what could be the issue?

The sweep and pipe features are just working for the straight lines, not the curves… I am using Rhino for almost 10 years and never experienced something like this.

Can you post the file with the curves here so someone can look?

Yes sure, here is the file with the curve.
(I switches 2 days ago from Rhino5 to Rhino6 - maybe there is something messed up with the settings…)

curve.3dm (28.5 KB)

OK, I see that, there is something really wonky with those curves…

    Valid curve.
    Open NURBS curve
      start = (-8.65961,-1425.32,-24.0776)
      end = (-5.14003,-1401.16,-13.097)
      degree = 5
      control points: non-rational, count=6 
      knots: uniform (delta=1), domain = **6.94412e+14 to 6.94412e+14**
      clamped at start and end

The domain for all of them is the same for start/end and is a huge number… How were those curves created? I tried to Reparameterize with Automatic on all the curves before joining, but that didn’t help, however reparameterizing with a domain 0 to 1 on all, then joining did… I can’t see offhand what’s wrong aside from that.

Note however that this is not specifically a V6 problem, as Pipe behaves the same way in V5… However, Reparameterize / Automatic in V5 does fix the problem, V6 not…

@pascal - one for the developers?

Thanks for checking the curves. The straight curves are created with ‘duplicate curve’ from a surface. The outcome was an 1 degree curve, therefore I haven’t rebuild it as it looked fine with the CV. The corner curves are blend curves (5 degree). I just figured out, when I rebuild the straight curves as and 3 degree curve and join it with the rest, the pipe function actually works.

Also there was a strange thing, when I tried to export the curves itself. The file size was first about 30 mb - but there was just the curves inside the file…

Hi - that’s probably something for the developers to take a look at, yes.
Question is what should be looked at. One thing is that Reparameterize with the Automatic option probably should work as it did in RH5. The other thing is how these straight lines were produced.

@alex.knorr, can you post the surface that those lines were taken off? And, probably more important, can you provide the steps on how to create that surface from scratch?

Hi Alex - try Reparameterize > Automatic on all the curves - that should behave better… but, as Mitch & Wim asked… how were these made?


That was what I tried first - didn’t work for me in V6.

Hmmm - I did have 7 open, not 6, and only tested one of the curves for Pipe, so maybe I’ve jumped the gun - I’ll have another look - thanks.