Sweep 2 rails tip problem

I select the first rail, then second and then the various cross sections but there is always a small section at the tip that it doesnt seem to sweep. I have tried clicking in different sections along the curves and have tried cross sections in different orders but still have a gap at the tip.sweep two rails problem.3dm (92.3 KB)

Hi Deborah- use the Point option at either end and snap to the intersection of the rails- select the lines in between. It might be better if the lines hit the rail curves- is that the intention?

-Pascal

Hi,
If you’re trying to generate a surface using Sweep2, you might use curves as ordered in this screenshot.


If you want your curve rails to become borders of the resulting surface, cross sections start and end points must “belong” to curve rails.

I have great difficulty working out which points are on the curve and which are off. Can the ones on the curve be highlighted to make selection easier?

I realised if I had my intersection snaps on I could just nudge the points back onto the line. Thanks all that worked!