Sweep 1 segments issue

Hi all there,

I am new to Rhino3d and came from SketchUp. I am redoing some of the objects and one action I can’t seem to get right. Here it is: when I sweep 1 Rails, the end results has sections what are squared. I would have expected a rounded object. Here a rectangle around a circle. Once exported the result clearly is segmented and non-round.

1
2

How do I make this work? Possibly, the Sweep 1 Rails is not intended to do this, what type of operation in Rhino is?

Thanks a million!

You probably need to bump the mesh settings so that you get a finer mesh.

A finer mesh - that certainly solves a part of it. On the screen I can see the more fine grained details, but when exporting (to step file for instance) it retains the coarse mesh …?

I believe you can set meshing options also on export

Hi,

STEP files do not store Rhino meshing information.

How do you check the exported step file? If you open it in Rhino again, Rhino will use the mesh settings from the template file.

Does this make sense?

-Willem

Assuming the rail is a perfect circle. You’re better off creating the object with a revolve. Sweeps too often produce wonky results.

I must belief Willem Derks is here on the right track: the viewers may the culprit. Using FreeCad and CadExchange, those tools retain the coarse segments. Reimporting a step file back in Rhino3d does show a smooth circle.

It may be the cad programs do apply a similar thing as Rhino with mesh properties, but in Rhino3d you can modify this and in the viewers you cannot.

I will try a revolve too, just to see if that makes any difference.

In the end I learned that the mesh settings are the problem, and mesh settings are client settings. Even in the “simple” CadExchange, I found the option to increase the mesh properties to a more fine level, solving my problem as it was never there. Indeed it wasn’t a problem, the drawings are precise. It is the rendering/representation of it that can deviate for performance reasons.

Thanks all for pushing me in the right direction!