"Sweep 1 Rail", Rhino Crashes Instantly if the rail is a block

crash
unhandled

#1

All is in the title. Crash @100%
CrashTest.3dm (37.3 KB)


#3

No crash here.
(6.3.18072.11251, 13.03.2018)


#4

Strange…, it crashes rhino on both machines. One Dell precision T7400 (old but still tough) and on my new laptop dell precision 7520.

Steps:
Select the rail
Select Sweep 1 Rail


#5

No crash here either, same version as Charles… Can you run SystemInfo in Rhino on the machine(s) in question and post here?

Ah, wait, I just got it to crash following your sequence… :frowning:

–Mitch


#6

T7400:

Rhino 6 SR3 2018-3-13 (Rhino 6, 6.3.18072.11251, Git hash:master @ c0a2028629d3ed3a538f0854c8ba021ae8c678b7)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Quadro 4000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 353.62)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 7-22-2015
Driver Version: 10.18.13.5362
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Dell 7520

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro M2200/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-9-2017
Driver Version: 22.21.13.8216
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB


#7

What’s happening here is a bit unpredictable, if I select the rail, then run Sweep1, I can usually get all the way to the dialog and even accept that, but the sweep is not created and Rhino crashes. Sometimes I have to run it again to make it crash… Bug report submitted: https://mcneel.myjetbrains.com/youtrack/issue/RH-44903