Sweep 1 failure (twisting and pinching)

I have been trying to model this snake ring for a week with the sweep 1 command but I continue to get a weird twisting/pinching on the bottom of the head rather than being flat like in the rest of the body. I attached the model (as well as the rail and cross sections next to it) so that you can take a look. I feel like it should be an easy fix but I can’t figure it out. Has anyone dealt with this before?

trial - Copy.3dm (481.4 KB)

Hi Sebastian - - you need to make sure all the cross section curves are lined up the same way- clockwise or anti-clockwise as you travel along the rail and all with the same seam point - the intersection of the section and the rail is a good location.



I had already tried switching the direction but not aligning the seam to the intersection. That made it work, thanks Pascal!

Now I’m having one other problem with the createUVcurve command. Hopefully you can help with this too since it might be due to the way the sweep command created the poly-surface. When I try to create the UV curve and I click on the top part of the polysurface it only selects a section of it rather than the entire top half like I intend to. It is demonstrated in the attached picture.

Hi Sebastian - if you make sure to align all the seam points to the same locations it will make one surface - the Int Osnap to the intersection of the path and each section curve is what I used - easy to find and since these all seem to be copies of an original, if I am not mistaken, they are all going to match up well.


Problem solved, thanks for the help!