Sweep 1 deviates from curve (by a lot)

How do I even begin to find out where the problem is here?

This is what happens in my work file (big file, relevant curves isolated):

However, when I export the curves and then try in a new file, I get this (the expected result):

So… I can repeat the problem in my own file, but not in a new file…

Then, to make matters worse, SelChain sometimes works and somtimes I have to click through all segments… yet, the curvature graph display seems fine (even at high zoom) and GCon also reports ok values:


This only happens on some sweeps in this file (again, I have many, several very similar and made from the same mirrored/rotated curves).

This time, I also made sure to check the tolerances (which are 0.001 because they need to go back into Solidworks for a customer).

rail-fail.3dm (200.3 KB)

(And just in case someone asks, no, I have not moved the curves from my big file to the new file above. It just did an “export selected” and nothing else.)

Now, my workaround is to take the result from the new file and paste it into my work file, but if anyone can give me any clues as to what is going on here, I’d appreciate it!

After posting the file above, I noticed the differences in freeform/roadlike, and just to be sure, I tried to switch in the new file, and then I got a third result:

Hm - none of that behavior so far here - it gets me the expected results. Can you try 7.11, you can get that by setting ‘Update frequency’ in Options > Updates and statistaics.


Hi Pascal,

This one is repeatable in 7.11

Pick the rail segments in a clockwise direction starting from the sweep shape then you get the invalid sweep. Pick them anti-clockwise you get a good sweep.

Pick them clockwise starting by the squiggle and you get another variant:

Pick them anti-clockwise starting by the squiggle and you get yet another:

I’ll leave you guys to find how many variants can be made!



OK, couldn’t resist: here’s one more:

Moved the sweep shape slightly away along the blue curve from its end before the sweep and picked segments clockwise. (Picking anti-clockwise worked correctly).


Making the curves’ direction consistent doesn’t help. Changing the arcs to nurbs arcs doesn’t help.

Something might have got fixed in 7.12, I will check 7.11.
Gotta pick in the right spot…

RH-65858 Sweep1: messy with edge chaining

1 Like

Here’s another example, rational and non-rational mixed this time:

rail-fail-2.3dm (461.4 KB)