SVG export error in WIP


(Mark Leichliter) #1

I’m getting the attached error message when attempting to export a simple file as SVG. Export selected and plain Export both produce the error. I can add the file if needed.

EDIT:I take that back – just tried PDF and AI export, received the same error message. Something is broken.

System Info:
Rhino 6 SR11 2018-10-16 (Public Build, 6.11.18289.12026, Git hash:master @ 6cffe3afd95b7adcad28afd20f3165b14929ad1a)
Licence type: Beta, build 2018-10-16
License details: Cloud Zoo. In use by: markleichliter ()
Expires on: 2018-11-30

Apple Intel 64-bit macOS Version 10.14 (Build 18A391) (Physical RAM: 16Gb)
Machine name: Mark’s MacBook Pro

AMD Radeon Pro 560 OpenGL Engine (OpenGL ver:4.1 ATI-2.0.36)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Driver Date: (null)
Driver Version: (null)
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.11.18289.12026
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.11.18289.12026
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.11.18289.12026
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/PlugIns/Alerter.rhp “Alerter” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.11.18289.12026
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 5.1.2015.132
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.11.18289.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 6.11.18289.12026


(Pascal Golay) #2

Hi Mark - thanks, I see this here as well.

-Pascal


(Steve Baer) #3

https://mcneel.myjetbrains.com/youtrack/issue/RH-45337

SVG is currently not hooked up in the WIP


(Pascal Golay) #4

Hi Steve - ah, OK, thanks, I’ll abort my bug report.The format shows up in the list though…

-Pascal