Surfaces not matching


#1

Hey,

I have a problem matching two surfaces:

  • both have identical surface degrees and point count

  • both have their points coinciding along the edgewhere the surfaces meet.

But somehow I can’t match them. When I turn on their isoparms, they are not aligned.

Is this due to the isoparms? And how can I move the isoparms to align then?

I’ve had this issue many times over and usually solved it by rebuilding the surfaces from scratch, but I hope there is a more efficient way to do this…


(David Cockey) #2

One cause of different shapes with coinciding control points is different parameterization.The default in Rhino is equal parameter intervals between knots. However it is possible to have unequal spacing. For instance if a curve is generated using InterpCrv or CurveThroughPt with the Knots=Chord or Knots=SqrtChrd and the interpolation points are not equally spaced the parameter intervals between knots will be unequal.


#3

i see,

In my case it was because I extended the surfaces (smooth). the same amount of extension didn’t result in the same extension length. I suspect that’s when parametrization got messed up.

So, there’s no way to control the location of your isoparms then by redrawing the base curves?

What I do as a workaround, is draw new curves with control points snapped to the old ones then build the new surfaces with loft command. That seems to solve it. But these surfaces only have degree one if vertical direction, so, its easy to loft in between the newly created curves.

When you have 3 or more points in vertical direction for each of the surfaces, you would loose any curvature continuity you might have achieved thus far. That’s why being able to align isoparms straight on the surface itself , without losing formerly created curvature continuity would be a great feature!


(David Cockey) #4

The extension length from ExtendSrf appears to be depend on the parameterization of the surface to be extended. So the different extension lengths may indicate the surfaces were parameterized differently before ExtendSrf.

Changing the isoparms would require changing knot spacing in parameter space. I don’t know if there is a way to do that directly.


(Pascal Golay) #5

Hi Arman - see if MakeUniform on these surfaces helps.

-Pascal


#6

that worked! great!
Tx.