Surface shading issue? or geometry issue?

The left one is created from 2 square and loft, then Cap. the right one is crated with 2 surface and sweep.
The shading looks different… and I think might be something is wrong? and I have been having this issue lately… simple command then the shading is a bit wired… just wondering is there some issue thats related to geometry?? 36%20PM

Hello - run DivideAlongCreases on the one on the left. Then run the command CreaseSplitting and make sure that is set to Enabled.


Thank you very much! It worked. it got rid of the wired shadow thing. but how do I prevent this in the future?

Hello - I suspect the CreaseSplitting that I mentioned above was set to Disabled, and if you enable it, this should not happen.


I did run the command… but it didn’t do anything… when I again did the loft >cap. it still did the same thing…

Hello - please run the CreaseSplitting command and make sure to set the option for Enable, then Enter. Does that sort it out?


thanks for bearing with me… this is what showed up when I type CreaseSplitting command…

hmm - I’d forgot that interface is different - sorry! Check the checkbox for Split Along Creases… Any luck?


I don’t think it did anything…

So, you need to run the command, make sure the box is checked and then click Done. For good measure run the command again and check that the box is still checked. It may pay to quit and restart Rhino, or open a new doc… though that should not be needed. Is that working (i.e.a newly created loft between say two rectangles is not a single surface)?


yes! it worked. thank you very much!