Surface Param in Grasshopper


I have a simple question, but I can’t solve it myself. When I add a surface param to Grasshopper and I want to set one surface, I click on my surface in Rhino, but it won’t add to the surface param in Grasshopper. I feel like it might have something to do with that I don’t have the bifocals option in the util area, but I am not sure, because I am a beginner in Grasshopper. How can I fix this?

Are you sure its a surface and not a polysurface? Look at the properties in Rhino, or try the Brep param and see if that works.

1 Like

Right-click the Srf param and choose ‘Set one Surface’:


And yeah, as Ethan has just suggested, make sure it’s a surface and not a brep, otherwise you need a Brep param instead of Srf param.