Surface issue


#1

Hi…

I’ve been using Rhino 3D for over 4 years now, and I’ve never had this issue come up before. I spread my workload over my office desktop and home office desktop… both are similar machines and run current copies of V5.

I started building a model of a trade show booth a few days ago on my home PC, worked on it at my office and then went to work on it again at home. I found a portion of the components seemed to be “missing” in rendered, shaded and pen views. I thought that I had accidently deleted something, but I found the pieces… but they were invisible. I could highlight the pieces, I could modify them (scale), but they had no fill, or lines. All layers were visible, no objects were hidden, I didn’t have any transparency applied to the pieces, and there was no texture mapping. When I opened the file back up at my office, everything was normal again.

I build a large portion of my models with closed polylines extruded to a required size. Just trying to troubleshoot, I exploded every surface in the model… which made everything visible again, but I couldn’t create solids at this point.

Rhino has always been a stable program for me, but I can’t think of anything else to look at right now to make sure that I don’t have this happen again. Does anyone have any suggestions for things to look for?

Thanks!

Jeff


#2

I think it would be helpful if you clarified exactly what you mean by “current copies of V5”, which operating system(s) you have, and which video cards and their drivers are in each machine. I’m pretty sure the McNeel folks would want to know this info. They probably will have even more questions and no doubt will want to have a copy of your .3dm file or a subset of it that displays the issue.


#3

Thanks…

At work I use an ASUS i7 @ 3.4, 16GB RAM, Windows 7 PRO with a NVIDIA Quadro 2000. At home it’s an HP I7 4770 @ 3.4, Windows 8 with a NVIDIA Geforce GT 635. Obviously not the same machine, but I have run the 2 without issue.

I’m at the office right now, and I was curious about the V5 release I had, and it prompted me to update the software. I did, and now the exact same problem just started on this machine. I’m attaching a few screenshots to show the difference, with a low-res copy from before.

.


#4

Hi Jeff, from your images i guess that either no render meshes are beeig built for certain objects or that the display mode (pen, artistic) is not showing tangent edges as expected. This can have various reasons. You might try this to sort out geometry related problems:

Use SelBadObjects command and if you find some, use ExtractBadSrf command to repair them.

Another thing you might try for objects which do not shade at all (if these are not bad objects), try this macro on a single object. At best, create a duplicate of your file before. Then select a single object only and run the macro below from within the _MacroEditor:

_Select _Pause
_NoEcho
_Explode
_ShrinkTrimmedSrf
_Reparameterize _Automatic
_RemoveFlippedNormals
_Join 

Btw. Please check if your Rendered display mode does cull backfaces, too. If surface normals are pointing inward, this could be a possible cause of objects beeing partially displayed in that display mode. Also try what happens in the Rendered display mode if you disable shadows.

Alternatively, please post a single part of your geometry which does not display properly in Wireframe display mode so we can try sorting out if it is a display driver, display mode or geometry related problem.

c.


(Pascal Golay) #5

Hi Clement- as a rule, I would use Reparameterize Automatic to set parameterization to approximate the dimensions of the object, unless you have a specific reason to set them 0-1.

-Pascal


#6

thanks Pascal, yes, it can be automatic as well in this case, shouldn`t matter in the OPs case i think as the V5 mesher is not anymore picky about reparameterisation. The 0-1 i personally did use since Rhino 3 to prepare surfaces for texture mapping and baking using AIR…vicious habits :wink:

c.


#7

As I read your first post:
You started the model at home, took it to the office and worked on it some more, then took it back home, where some parts wouldn’t display properly in rendered, shaded and pen views.

You said there was a difference in Rhino versions between the home and office machines, but you then updated the office Rhino, which I took to mean they are now both the same (is this correct?), and now the display issues are the same on both machines.

I think it would be useful to know exactly which Rhino version you have now on the two machines and exactly which version was on the office machine before you updated it.

Are you able to recall which machine the troublesome objects were created and/or last edited on? Or were some made on each machine?

Did you check that you have the latest drivers from nVidia for each video card?