Surface from .igs problem


#1

Hi together,

I want to import a surface (more complex than the one in the pic, but same problem). whenever I rebuild the surface, I can see that it thinks its a trimmed surface. I modelt the surface with a loft in solid works.

Any advice on how to do this right? Where lies the problem?

Later I want to apply paneling, but then the points are also created outside the actual surface, leading to problems…

Thanks,
Alex


(Margaret Becker) #2

Does the ShrinkTrimmedSrf command do you any good?


#3

IGES files can be problematic. I find STEP files to be more reliable if that is an option for you.


(John Brock) #4

I think the IGES flavor you’re using is splitting the surface at 180 degrees. MergeSrf should make them a single surface again.


#5

Thanks for your help, but the surface from the step file is even more extended, in this case to a hole cone!

The ShrinkTrimmedSrf command did the trick! Thanks margaret! After that the rebuild did what I want.

Thanks @ all!


#6

Just for general info, solid modelers often use trimmed surfaces even where an untrimmed “natural edge” surface will do the job. And they mostly do not like surfaces that are closed in one direction or the other, so cylinders, cones, spheres and the like are split into 2 or more parts.

Imported surfaces from these programs will have the same structure in Rhino…

–Mitch