Summer computer, Rhino 7. Fragmented curves, flickering

Attached is a file. It was stable and normal on the computer I used to make it, a Win 10 machine using Rhino 7. But a thousand miles West, on a summer computer (also Win 10) I get an image in which the lines are fragmented and the whole scene flickers. You can flicker it by shifting the scene with a mouse, or by repeatedly toggling labels, e.g. the lightbulb for the V 60 curve label. Curiously the effect is not a simple on-off toggle. Instead, it runs the model through a multi-step sequence of changes.

The graphics card is an AMD/ATI FirePro V. Driver is said to be ok and will not update (there may exist no update.)

The model is not usable in this state, but when you click around on it, the unfragmented original lines are sometimes apparent and (momentarily) intact.

How to proceed?

Thank you for your insights.
fragmented crvs.3dm (49.0 KB)

. .

Hi MCG,

Please run SystemInfo in the Rhino command line and post the results. Thanks

My guess is in Rhino Options > View > OpenGL, if you uncheck the GPU Tessellation option it will fix it.
AMD’s current drivers don’t work correctly on older GPUs.

Wow. Back in business. I owe you one John, your solution seems to have completely solved it. .

Japhy, here is a copy of the System info made before I unchecked tesselation. May provide some insight into what was going on here.

Rhino 7 SR30 2023-6-12 (Rhino 7, 7.30.23163.13001, Git hash:master @ f695e494df78377a81b2b95edb99c6067e324b33)
License type: Commercial, build 2023-06-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: ATI FirePro V (FireGL V) Graphics Adapter (AMD) Memory: 2GB, Driver date: 11-4-2015 (M-D-Y). OpenGL Ver: 4.5.13399 Compatibility Profile Context FireGL 15.201.1151.1008
> Accelerated graphics device with 6 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.5 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.40
Driver Date: 11-4-2015
Driver Version: 15.201.1151.1008
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.30.23163.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Many thanks to you both. Michael

As a footnote I should add that the desktop I used to make this model runs an nvidia card. The older desktop I use in summer has the ATI Firepro V.

No surprise.
NVidia has a better track record with good openGL drivers.
AMD’s new drivers seems to work well on their new cards but not on their older cards like your FirePro.