Substance Material, Open Edges

@nathanletwory @BrianJ
Dear All, when applying the below Substance material, all edges in the mesh that are not welded open up visibly. I tried changing all the available Substance material settings, to no avail. The mesh is watertight - when analyzing it with Edge Tools, no open edges show, it is valid, not degenerate, mesh normals are unified. Unfortunately I cannot share the model publicly.

Any help would be greatly appreciated. Might this be a bug?

Hi Silvano - it looks like is there is a displacement channel - try turning that off kif you can.


@pascal Thanks for the pointer. There was a displacement multiplier available. Setting it to 0 solved the issue. Any other value, even fractions of 0.001 in a mm file, would result in open edges.

@silvano If you wanted to use the “Height” option in the Substance material on this object, I would ExtractRenderMesh > and then WeldEdges on that mesh. My guess is that the hard edges in it were being seen as unwelded edges causing the displacement to separate.