Subselection + displacement in v8

Hi,

i’m following @BrianJ tutorial for Displacement using v8 instead of v7 but it seems subselection doesn’t work anymore. If I apply displacement to the hole polysrf it works but if i select only a part it doesn’t.
Anyone else with this problem?

Thanks in advance

[System info:
Rhino 8 SR8 2024-5-21 (Rhino 8, 8.8.24142.13001, Git hash:master @ cf2a36827c139ab301c2560ae9153ea7a926bdec)
License type: Comercial, build 2024-05-21
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 64GB)
.NET 7.0.19

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 1-18-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.23
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-18-2024
Driver Version: 31.0.15.5123
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\CommandTracker\7.0.8201.28462\CommandTracker.rhp “CommandTracker” 7.0.8201.28462
C:\Users\Usuario\AppData\Roaming\McNeel\Rhinoceros\8.0\Plug-ins\Crayon (39629248-4fa6-47b8-83c7-745a7efea259)\1.2.0.0\Crayon\Crayon.rhp “Crayon” 1.0.0.0
D:\00 RESOURCES\080_RH7\blockeditnew202310240119\BlockEditNew.rhp “BlockEdit” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24142.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

]

Hi @12Lab,

Try sub selecting the faces after displacement, where you don’t want it to disable the displacement property for just those. Any luck?

The behavior may have changed in the order you need to do it, I’ll check and file a bug if needed.

1 Like

thanks a lot!

as you said the order changed, first i apply to the whole polysrf and then disable the parts i want “clean”

Yes, there’s a bug, and difference from v7, sorry! It works in v8 as I described but it’s a pain to deselect where you don’t want the displacement after. Filed as https://mcneel.myjetbrains.com/youtrack/issue/RH-82114 Thanks for the report.

1 Like