SubDSweep2 glitch

SubDSweep2, with subd friendly curves, is giving me this glitch:

The glitch happens with or without a second cross section curve:

In addition to going the wrong way, the point twists, with or without additional cross section curves.

1 Like

post the file please with steps to repeat?

I drew curves using “subD friendly”
Then I ran SubDSweep2
Then when it failed, I tried scaling the initial cross section curve and relocating it to various points along the rails to see if it could prevent the twist. It didn’t work.
subDsweep2.3dm (143.9 KB)

Hello - I get this in the latest-

Does not look quite 100%, but better than your result, for some reason. Adding segments to the rail direction helps. The only way, so far, that I can get the right answer is to trim the rail curves at the small cross-section and then make them SubD friendly again.

Ah, OK I see -you get that if there is no second cross section - here, too. It is fine if you do move the ends of a curves apart slightly…

RH-61362 SubDSweep2:


1 Like

I’m using the latest version, from yesterday. Weird.

As for

You mean the point, yes?

RH-61362 is fixed in the latest Rhino 7 Service Release Candidate