SubD vertices don't align to curve

I want to get a more circular end from a _MultiPipe.
The idea is to transform align the vertices to a circle.
But the vertices are away from the circle, even those that were already on the circle.
What’s wrong, or what do I do wrong?
Align.3dm (98.3 KB)

Hi @Charles ,

I filed this as https://mcneel.myjetbrains.com/youtrack/issue/RH-68931 for future reference. The control points or where you see the verts in box mode with the SubD are what are getting aligned to the curve but I agree either verts or ctrl pts ought to work. The workaround currently is to make a surface with the circle and then use Pull instead to get the verts on that…

I also have this request on file https://mcneel.myjetbrains.com/youtrack/issue/RH-55054 to make edge loops circular. I’ll add this post to that too.

1 Like

Thanks @BrianJ

I scaled the verts to get a quick result.
_Pull is a better intermediate solution, thanks.

Even better would be the _Circlify as mentioned in 55054.
Perhaps as a simple script.

  • Solved for today.

there are similar issues / questions…

i still love the “setPtPolar” command i wished here

2 Likes

see also here

(and yes, dear discourse this connection is similar to a body of post …)

1 Like

The new TestSubDEdgeMatch: A new command to match SubDs to other Rhino objects should be able to help you here, @Charles. I just tried it in your example. Looking forward to hearing your thoughts on the command!

1 Like

Can you please tell me what version of Rhino this is?

Gladly, @dinhchien2103. This command is in this week’s Rhino 8 WIP for Windows or MacOS.

How can I adjust it like you?
here is mine
image
and yours
image

Oh, you the difference is only in the look of the Rhino interface: you are running Rhino on Windows, and I am using Rhino on Mac in the video. However, you have access exactly the same command parameters and functionality as I do. In other words, you don’t need to adjust anything to get the same match results a Mac user would :slight_smile:

image
image
I mean 1 is knots, 1 is editpoints, why is there such a change in choice?

In the screenshots above, are you trying to match 2 different targets?

The options available in MatchLocations will depend on how compatible the SubD boundary is with the target curve or surface boundary you want to match. Specifically, the options MatchLocations=EditPoints or MatchLocations=Knots will only be available if the number of edit points or knots in the target is equal to the number of control points in the boundary of the SubD you want to modify. If this is not the case, then neither of these options will be available.

The options MatchLocations=UniformParameters and MatchLocations=ClosestPoints will consistently be available, regardless of the structure of the target.

Take a look at the Tips and Tricks section in this post for more details on how the command works, or take a look at this introduction video, starting at minute 7:49.

1 Like

What you guessed is correct, my subD mesh is less than the required condition so knots appear, maybe a stupid question but can you show me how to create a subD mesh like the picture on the left?

one of the examples:
1

1 Like

tks very much

Very nice, that’s helpful.
Works well!

1 Like

Great to hear, @Charles – Thanks!
@dinhchien2103, in addition to SubDivide, another approach to increase the number of edges in a SubD is using the command InsertEdge. Unlike SubDivide, which densifies the SubD globally, the InsertEdge command will only add a row of edges to the SubD locally. The choice of one versus the other will depend on what you are after.