SubD in faceted mode shows textures incorrectly

Hi McNeel team,

I’ve found another SubD bug: Faceted mode does not show textures correctly:



PS: Can you please, please, please hire one (or another one) QA person? This is all super basic stuff that should all be working. And when it doesn’t it should be all spotted by your team, not mine.

1 Like

@gustojunk I’m not able to repeat this. Please attach the model which reproduces the problem. Also, what version of Rhino are you running?


HI David, latest version you have shared this week.

I just isolated those element for you:

attached .3dm here:

replicated_UV_space_bug_faceted_subD_gf_201009.3dm (2.5 MB)



Hi @gustojunk,

I can repeat it with the provided .3dm. It seems like one has to be in Shaded mode with SetObjectDisplayMode=Rendered. If you switch to Rendered mode it looks correct.


Hi David,

Sorry for sending this example with a SetObjectDsiplay mode applied, that was not intentional, nor the focus of the bug, so please don’t get confused by it.

This is happening on Rendered view regardless of custom display modes. In fact if you select teh SubD object and run this:
! _SetObjectDisplayMode _Pause _Mode _UseView

…you will still see the mapping bug in faceted mode.


Hi @gustojunk ,

Is this the type of bug you’re talking about?

If not, then I’m not able to reproduce the bug in Rendered mode the way you described. Do you have ATP (Advanced Texture Preview) disabled?


Ooooooh!!! I did! I think I did that last week because my Rhino was melting with some PBR materials so I was trying to see if I could turn some goodness off to make it display faster. Re-enabling advanced texturing solved the problem.

…I still don’t understand why that makes a difference.

Sorry for the confusion.


Glad it’s working! There’s still a bug in our code of course because it should work even without it enabled, so the YouTrack item stays open.