Subd face selection highlight doesn't refresh in ghosted view - R8.2 Bug?

Hey there,

I can’t seem to figure out this display issue:

When I’m selecting a subd face while in ghosted view, I can see the adjacent edges highlighted, but not the face itself. It works fine in shaded view. And it does work even in ghosted view, if I have another viewport open in parallel with shaded view. If not, the subd face just won’t highlight after selecting it. Only when I start manipulating it (e.g. with the gumball) it becomes highlighted.

selected a subd face:

pulled the subd face:

Some more details:

If I try the same with meshes, there’s no such issue. I see the highlight just fine. When I start in shaded view, then select the subd face, then switch to ghosted, it will show. However if I deselect it then, it will stay highlighted. even if I select another face. That means I’ll have two faces highlighted - one showing a highlighted face (the one previously selected) and the other showing the edge outline (the one currently selected). The editing itself works, but it’s getting confusing to always have the previously selected face still highlighted.

I am having the same issue on my desktop PC and laptop. Latest driver installed.

Would be grateful for any clue leading to a fix! Thanks in advance!

Manuel

System Info:

Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13001, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Kommerziell, build 2023-12-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1660 SUPER (NVidia) Memory: 6GB, Driver date: 12-6-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.33
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port 0

Secondary graphics devices.
Intel(R) HD Graphics 3000 (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y).
> Integrated graphics device with 2 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2023
Driver Version: 31.0.15.4633
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi Manuel, thanks for the report, I’ll see if I can reproduce that.

I see it, thanks.
RH-79311 Display: SubD face highlight in ghosted mode varies

-Pascal

I should add that this effect is limited to the smooth display mode in subd objects. As soon as I toggle back to flat, everything works as expected.

Ah - OK, thanks, I see that too.

-Pascal