SubD edge loop hotkey

Hi,

Is cntl+shift double click on a Subd loop still a hotkey for edge loop? I just realize that the hotkey I am used to hot keys for edge loop / face loop and ring loop but they are all gone after this update. Is it just me? Thanks!

Yes, Ctrl + Shift + double click should still select an edge loop. Can you provide a 3dm and screenshot of the display mode you’re in as well as the results of your SystemInfo command if this isn’t working for you?

1 Like

edgeloop.3dm (4.6 MB)

Hi @BrianJ Here it is.

Rhino 7 SR0 2020-10-27 (Rhino 7 BETA, 7.0.20301.12003, Git hash:master @ 4c0b73af74d105119977b2e4ef0738d956e83af0)
License type: Educational, build 2020-10-27
License details: Cloud Zoo
Expires on: 2020-12-11

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version: 27.21.14.5206
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7 WIP\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7 WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7 WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20301.12003
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”


Non of the display mode work not just ghosted and shaded.

PS. I love your tutorials on Rhino Tech Tips. I watched them multiple times!

Thank you

Thanks! I’m not seeing an issue here with edge loop selection. That face doesn’t have one loop surrounding it though so maybe that is what you’re looking for. Here’s what I get with Ctrl + Shift+ double click over an edge, are you doing something different? I also show the “SubDFaceEdgeVertexToggle” command which will give you the border edges from that face.

Hi @BrianJ no your video is what I was looking for. I used SubD on WIP a month ago and it was fine. Ring loop face loop and edge loop were all working. Do you think if I repair the app would make any difference? I tested on a simple SubD plane or a SubD box it just stopped working for me for some unknown reason.

Can you sub-object select one edge only? If not, I wonder if your selection filters are the cause.

sub object select is working fine. I can select on one single edge or face or vertex.

all working here as expected… post your systeminfo from rhino?

Rhino 7 SR0 2020-11-4 (Rhino 7 BETA, 7.0.20309.06003, Git hash:master @ 368ab021c8426434a95c36999f545f918e04df2c)
License type: Educational, build 2020-11-04
License details: Cloud Zoo
Expires on: 2020-12-19

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version: 27.21.14.5206
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 7 WIP\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0
C:\Users\hogan\Dropbox-E-Library- Set Design resources- Rhino\FlipView\FlipView.rhp “FlipView”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20309.6003
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

are you using any custom features in your ghosted view?

I did but I just restored to default. The problem remains. I lost the edge/ring/face loop feature whatsoever in all view mode.

so to be clear, if you double click an edge, a loop does not select?

If you pick an edge and then run the SelEdgeLoop command, does a loop not select?

If you pick and edge and then run the SelEdgeRing you do not get a ring?

Hi Kyle

If I control shift double click on an edge it does basic sub-oject select - an edge got selected.

If you pick an edge and then run the SelEdgeLoop command, does a loop not select? The SelEdgeLoop command works fine by doing so.

If you pick and edge and then run the SelEdgeRing you do not get a ring?
Yes I do. But control + double click hotkey doesn’t work.

if you set a selection filter to edges only and double click on an edge (no crtl+shift) does it work?

Hi Kyle, it works! What was the problem? But if this is the alternative way for edge/face loop what about ring loop (I try adding alt but didn’t work). Is there a place in the setting for built-in hotkeys like this? It’s not under keyboard… I just Repair Rhino but the problem is still there.
Thanks

ring does not have the double click shortcut… you have to use the seledgering command

I think there is: control shift-click one ring and ctrl shift alt the next ring. Or something similar. Wish I could try it out and tell you the exact steps.

@BrianJ Is there a way to reset R7 to its default setting in this case? I tried repaired and also reinstalled but no luck. Is there anything else you would suggest to me try out? I couldn’t think of anything that would cause this issue. Hope to get this solve eventually…
Thanks

I’ve been trying to make it not work here to suggest things to reset or check but nothing so far has been the cause for you which makes my leading guess that your mouse has something wrong with the contact under the LMB click like dust/dirt or your double click speed is too slow to make the loop selection happen. Have you tried another mouse?

Hi @BrianJ I thought about that and had checked with a different mouse + cleaning my usual mouse. Also tried to adjust the double click speed.