Stream has no data error message

I keep getting a “stream has no data” error messages trying to login to my Rhino WIP. I need to use it asap for a deadline. All of my files were created in WIP so I cannot open in Rhino 6.

Can anyone help?

I see you have a V6 license in your login account.
Are you logging into your account when The WIP asls for a license?
If not, that’s the fix.

Hi @r.bukhbinder can you please send a screenshot of this error?

@aj1 this may need your assistance.

Here it is.

Yes I have been logging into my account when the WIP asks for a license. That is when the error message pops up.

Hi @r.bukhbinder,

Please try the following:

  1. Close Rhino.

  2. On the Finder, please click on the Go, then click Go to Folder... and enter ~/Library/Application Support/McNeel/Rhinoceros/7.0/License Manager/Licenses

  3. PM me the files in this folder and then delete all of them.

  4. Start Rhino again. You should be asked to login.

@aj1 How should I PM you? Also, I am not able to compress the files. I’m not sure if they will all load.

@r.bukhbinder if you click on my profile you should be able to Message me. Otherwise email me at

The files should definitely be less than 5MB, so no compression is needed.

HUZAH! It worked. Thank you so much @aj1!!!

@aj1 is there anything we can do to detect and fix this problem for users automatically?

It appears that this whole thing started with a R60-BTA license key in the mix. I’ve added code to our license validation system to disallow Rhino 6 Beta keys, since they’ve been out of commission for over two years, and also cause confusion.

I’m not exactly sure what the problem is here. It looks at first glance to be a corrupted file.

Panic!!! Reinstalled but same error. Logged in/out same error. REALLY important delivery this week. Using online licence login thing…

Have you tried steps 1,2 and 4 from this reply?

Thanks for being so fast! Theres no /7.0/ just the /6.0/ i have an online login for the licence

If you have the 6.0 folder with License\ Manager/Licenses in that I believe you should be able to move the files to some other location (from Rhino POV tht is the same as removing, but you’ll have them as a ‘backup’). Then start Rhino again.

I tried everything… deleted the files, renamed folders, closed rhino, reinstalled rhino, logging in, logging out… still getting the “stream has no data” RH6 works fine, just the WIP suddenly gives me this. Crashed a few times with short intervals just before it stopped working, HDD showed as full and i noticed my file was a gig maybe it was too big? HDD has plenty space now during my reinstallation and trying different things…

Not sure why there wouldn’t be a ~/Library/Application Support/McNeel/Rhinoceros/7.0 folder for you. @aj1, any ideas here?

I made 7.0 and pasted the tree from the 6.0 in there but that didn’t work. not that i thought it would :slight_smile:

Hi Erik can you please post a screenshot of the error you are seeing?

Also, what folders do you have under ~/Library/Application Support/McNeel/Rhinoceros?