Stream has no data error message

HUZAH! It worked. Thank you so much @aj1!!!

@aj1 is there anything we can do to detect and fix this problem for users automatically?

It appears that this whole thing started with a R60-BTA license key in the mix. I’ve added code to our license validation system to disallow Rhino 6 Beta keys, since they’ve been out of commission for over two years, and also cause confusion.

I’m not exactly sure what the problem is here. It looks at first glance to be a corrupted file.

Panic!!! Reinstalled but same error. Logged in/out same error. REALLY important delivery this week. Using online licence login thing…

Have you tried steps 1,2 and 4 from this reply?

Thanks for being so fast! Theres no /7.0/ just the /6.0/ i have an online login for the licence

If you have the 6.0 folder with License\ Manager/Licenses in that I believe you should be able to move the files to some other location (from Rhino POV tht is the same as removing, but you’ll have them as a ‘backup’). Then start Rhino again.

I tried everything… deleted the files, renamed folders, closed rhino, reinstalled rhino, logging in, logging out… still getting the “stream has no data” RH6 works fine, just the WIP suddenly gives me this. Crashed a few times with short intervals just before it stopped working, HDD showed as full and i noticed my file was a gig maybe it was too big? HDD has plenty space now during my reinstallation and trying different things…

Not sure why there wouldn’t be a ~/Library/Application Support/McNeel/Rhinoceros/7.0 folder for you. @aj1, any ideas here?

I made 7.0 and pasted the tree from the 6.0 in there but that didn’t work. not that i thought it would :slight_smile:

Hi Erik can you please post a screenshot of the error you are seeing?

Also, what folders do you have under ~/Library/Application Support/McNeel/Rhinoceros?

Thanks. Did you by chance omit the ~ in ~/Library/Application\ Support/McNeel/Rhinoceros/7.0/License\ Manager/Licenses When using Go to Folder... in the finder?

Well i looked around a bit more and yes… it was located in Macintosh HD/Users/Shared/McNeel/Rhinoceros/7.0/Licence Manager/Licenses/
But removing it and letting rhinoWIP grab a new one from the online login still gives me the same error message. It felt like yeah finally this is it!! …but it wasn’t. Trying to work it out in RH6 for now.

I got it now. I searched “McNeel” in finder and there were several for some reason. I have both rh6 and wip installed but this computer is just a couple of months old so… anyways, i deleted the “Licence” folder from all of them and restarted rhinoWIP and this time it worked! Mac is so backwards with its file handling i cant find this McNeel tree any other way, its not under Mac HD or any other item i can see and i cant get it to show the complete tree from the one that worked in the end so i dont know where it is located its just floating around inside the HD…

I think you would have had best results if you had followed the instructions to the character. But great to hear you’re back in the game again. Enjoy Rhino!

Thanks yes my error i didnt catch to use “go to” in the drop down in finder. Instead i pasted the path into the search box. Thanks again!
PS SubD is really good now!

Same Issue, Please help!
Thank you

I think the folder you’re looking for is here:
~/Library/Application Support/McNeel/Rhinoceros/7.0/License Manager/Licenses

Detailed instructions in this post:

-Kevin

Thank you, it worked and Grasshopper works again but I lost the work in the file I was last working on last.
Files saved but the work within didnt, any way to recover?

Thanks for the quick reply