Strange shading variations in clipping plane sections. help

hatch
clippingplane
shaded
unhandled

#1

Does anyone know why certain sections show strange changes in color of hatching when using the shaded view? How do I set it to do one color/shade without variation? Thank you.


(Pascal Golay) #2

Hi Peter - can you please post here or send to tech@mcneel.com a simple file that shows the problem?
thanks,

-Pascal


#3

I just did a ton of trial and error, and found that whenever I have a block in a drawing, I get this strange shading changes, even though the blocks are seperate. When I hide or delete the block items, the hatching looks normal.

Attached you’ll find a file with a solid and some vertical block elements. If you print it with the vertical blocks, you should get strange hatching changes, but if you hide those elements, the hatching looks normal…

Ideas why these blocks are causing this issue, and how to resolve this so I dont have to rely on manual hatching (too time consuming especially after client makes big changes)? I have this problem with every drawing that has a shaded clipping plane! :frowning: example-fill-problem.3dm (800.3 KB)
example-fill-problem.pdf (59.0 KB)


Clipping plane fill as cross hatch?
(Pascal Golay) #4

Hi Peter - is the attached what you expect?
example-fill-problem.pdf (33.5 KB)

-Pascal


#5

Yes that looks right. What change did you make so the shading come out consistent?


(Pascal Golay) #6

Hi Peter - I didn’t, unfortunately - it just works here… it may be a video card specific thing - what card do you have?

-Pascal


#7

geforce gtx 965m… Strange. But when I hide those objects or even explode them, the shading words well.


(Pascal Golay) #8

Hi Peter - try: BlockEdit one of these blocks, select everything, and ShrinkTrimmedSrf and OK to exit the block editor. … any better?

-Pascal


#9

Didnt make a difference. Any other possible solutions? So far the only thing that works is exploding :tired_face:


(Pascal Golay) #10

Hi Peter - I do not have a better idea at the moment… I guess making sure the video card drivers are up to date, as usual, is one thing to verify.

Have you tried the same file in V6/WIP, by the way?

-Pascal


#11

Thanks Pascal. I just updated the graphics driver and no change. I’m not crazy about jumping into v6 yet because I have everything set up the way I like it in my version and don’t want to have to redo all the settings/customizations. I’ll wait for full release.


(Pascal Golay) #12

Hi Peter - no pressure or anything but V6 /WIP runs alongside V5, not instead of… =)

-Pascal


(Wim Dekeyser) #13

By the looks of it, you are on RH5 SR9. Why not update to SR13?
Printing that example file showed no problems here either.