Strange dialog box


#1

… appears in the latest WIP (6.10.18261.18456, 2018-09-18) when opening a file.

Have to click “ok” six times to make it disappear.

Philip


"Plug-in developer run time debugging" pops up a lot RH6 WIP 6.10
#2

Same dialogue also here, popped on the UnTrim command.
took 15 ok clicks to make it go away.
thanks a lot

Akash


(John Brock) #3

I’m not seeing that and I don’t know what to ask for so we can see what’s special about your system that causes this.

Maybe @dan will have an idea.


#5

SystemInfo_MacBookPro.txt (9.2 KB)
SystemInfo_iMacPro.txt (2.2 KB)

Philip


(Kev R) #6

I just saw this too.

Launched the latest WIP and clicked “New Model” on the splash screen - the dialog shown above popped up and took 6 clicks to dismiss.

-Kevin


(Dan Belcher) #7

Whew, this took a bit of work to reproduce, but I believe I have. Logged in RH-48632.

Now, can you do a little experimentation for me please? I suspect your Rhino language is set to “Use MacOS language”, is that correct?

If so, what happens if you switch this to be explicit to your language? @Philip I suspect this problem will go away if you set this to “Français” and restart Rhino, is that correct? (This is a just a test to confirm a hunch).

I also suspect everyone who is reporting this is running macOS is a something other than English (US).


(Kev R) #8

I’m running MacOS in English, but have Russian language support installed.

Tried your suggestion and changed my Rhino language from “Use MacOS language” to “English”, but the dialog still came up when I clicked “New Model” on the splash screen.

I set my Rhino language to “Français” as you suggested to Philip, and when I clicked “New Model” I didn’t get the dialog box. Quit and restarted Rhino and the problem is back. Changed Rhino language from “Français” to “English” and no problem the first time I launched Rhino. Quit and restarted Rhino and the problem is back again. Changed Rhino language from “English” to “Русский” - same result - fixed for one launch then problem returned.

It seems that changing the Rhino language fixes the problem for one launch of Rhino but if you quit and restart the problem returns.

Hope this helps.

-Kevin


#9

MacOS is in US English here.

thanks for looking into this

Akash


(Dan Belcher) #10

Thanks for the additional info @kev.r and @Akash. Hrmmm, this confounds my hypothesis a bit. Good to know.


#11

Sorry for the delay… I’ve been very busy.

Yes. However, this is getting really weird… Starting my iMac, starting Rhino V6, opening a file and the dialog box pops up (the dialog box has never appeared when clicking ‘new model’). Closing and reopening Rhino, opening the same file again - and the dialog doesn’t appear. If a open another file it does appear again - but not with all ‘new’ files! That’s strange. It seems to be a bit random…

Well, yes, but as I said I can’t get it to appear anyway when opening a file that has already been opened in an earlier session - or opening some random file (if I’m lucky). Sometimes it appears, sometimes it doesn’t. I don’t know what more to say…

Running Mac OS in English here.

Philip


(Dan Belcher) #12

Thanks for the additional info. In fact, I was mistaken; this has nothing to do with language settings. @marlin figure out what was causing this and it has to do with the new load-protecting plugins. Sorry for the red-herring. A fix will be in the next RhinoWIP.


#13

Great! :+1: Thanks!

Philip


(Dan Taylor) #15

Glad to hear you figured this one out! Had this issue as well. Just a minor annoyance. MacBook Pro 13" w Touch Bar for me running Mac OS Mojave.


(Dan Belcher) #16

This should be fixed in the latest RhinoWIP. Please give it a try.