Strange behaviour of copying elements in GH

I try to build a simple model using Grasshopper, and there is a problem: I have a set of 2 intersecting elements (a rectangle and an ellipse) and when I use them as curves for creating walls it works fine. Then, I find intersection points, trim the curves and join them into one single entity. I copy it several times along the Z axis (for getting a set of levels), and here the problem occurs. Grasshopper is telling me the cutves are not planar, despite they are… See the picture:

When I bake the trimmed and joined curve I still can use it as a curve for creating a wall. The more, I still can use this curve in Grasshopper, the copying operation makes it impossible… It looks like the copy operation is messing something…
How can I solve this problem?
Regards, Jaro

Hi Jaro,

This is quite weird, could you send the grasshopper file, or at least a part of it?
Otherwise is too difficult for us to reproduce the issue.

Thank you

Hello Ramon,
It’s nothing top secret. I haven’t translated anything, but I am sure you will make out the definition.
Cheers, Jaro (22.8 KB)

Hi Jaro,

It seems that the problem happens only from the Grasshopper VisualARQ Wall with some polycurves, because with a simpler shapes it works fine, as well as without GH. I will let you know when this issue is fixed.

Kind regards

Hello Ramon,
I tried the definition with Rhino 5, and it worked…:

…until I changed the number of floors:

Every change gave wrong solutions, but with the same floors missing:

It is very strange :wink:
Cheers, Jaro

Hi @jerry.bakowski,

The issue has been fixed and will be available on the 2.8 version which will be released soon.

Fantastic :smiley: