Strange Behaviour, Bend Command Distortion


#1

I don’t know if this is related to any other fault, but I am having trouble with the bend command

The left hand bend is fine, but the right hand bend has suffered severe distortion. I get this fault regardless of which side is bent first. The fault has also occurred on plate work with no features (cutouts) on the plate. I did not have this fault with the old version of Rhino. Bending is along a duplicate spine, in this case the plate is 5mm thick and the spine length 4mm.

Bending the plate in the opposite direction does shifts the fault to the opposite bend.


#2

hey bill.
i doubt this is an actual bug (or if it is- i doubt it’s a mac specific bug)

can you post a .3dm here which has the sheet in its pre-bent state?


#3

Cheers Jeff, no problem here’s a sheet with the 90 degree bends

Bend Failure.3dm (133.7 KB)

Jeff, forgot to mention, prior to the big update I had been doing a load of CAD involving bending sheet metal for a fabricator so this was simple stuff prior, thats why I think its a new bug or consiquence of the update.


#4

hmm… yeah, i’m getting the same thing… i also tried drawing a curve with the desired shape then flowing to it and got similar results.

i think your thread title might be misleading though and that some of the people who would be able to help in this situation may not open the thread… (my not so helpful suggestion would be to draw this thing differently without bending/twisting/etc as that introduces all sorts of (imo) unnecessary complexity to the surface)…

but that still doesn’t get to the bottom of why the bend (and other) commands are causing such deformity because it seems like this should bend OK… it would also be interesting to see if a windows user is getting the same type of results… maybe @Helvetosaur can look at it as he generally browses the mac subforum?


#5

Thanks for taking the time Jeff, I had been struggling all morning with this one trying to find what I was doing wrong. Yeah I can extrude the plate then boolean the cutouts which is a pain aligning everything.


#6

Jeff, you are right I just tested this on my MS laptop and the fault is present in Rhino 4.0 What is really interesting is I found a work around… Do a sacrificial bend on an extension and the fault occurs, however there after all bends perform correctly. See example

Sacrificial Bend.3dm (188.7 KB)

Just doesn’t make sense, but at least I have a work around for now. Can’t explain why it was working a week ago on the Mac though ?


#7

i think what may be happening is along these lines-- your sacrificial bend is adding more points to the object instead of the 4 corner points which then allows it to be deformable…

i did a quick experiment in which i built the flat sheet of metal a little differently than i assume you did and the bend command then appears to work properly on it…

use the _Plane command to draw your 300x800 rectangle… make sure to use the Deformable option (in which i entered 3 for the degree and 10 for the point count in both the U & V direction – your situation probably won’t require that many points in the Y direction and i’m unsure about which degree would work best for you)…

now offset or extrude that surface to your 5mm thickness then bend this version… it should work out a lot better for you.
?


#8

Thanks Jeff, thats a good workable solution. I just tried lots of other alternatives, but yours gives best results. Many thanks again Jeff.

Rhino Team, you still have a problem bending extruded polysurfaces generated from curves.


(Pascal Golay) #9

Hi Bill, Jeff - You can also force it by inserting a bunch of knots in the area of the bends, then extruding the face.

I don’t know if maybe Rhino can be made to do this itself in the bend span- I’ll put it on the pile anyway-

-Pascal


#10

Pascal,
the knot command is just what I wanted and the screencast is a great resource for passing on the knowledge. Many thanks for your help.


#11

good to know @pascal… thx


(Pascal Golay) #12

Hi Bill- that is ‘InsertKnot’… sorry, I did not say so in my note.

-Pascal