Straight corners appear rounded in print display mode

I’m teaching Rhino to architecture students, and today a student showed me a plan drawing where the corners appear rounded (but they are actually drawn correct with 90 degrees corners). Why is this happening and how can i turn it off? I guess it’s a view setting or something I guess?

Regards Sindre

Please provide more information/example:

Sorry Fred_C, haven’t done this before.
Here you can see the problem and how it appears in printDisplay mode…
How can I get the corners to apear 90 degrees as they are designed.

Hope somebody can help.

1 Like

Guideline 3. Attach minimal versions of all the relevant files snap00%2011-6-2019

Hi Sindre - line segments have rounded ends -


to avoid the opposite problem -


So, the thicker the lines, the more obvious these ends become.



Thank you, but the best would be if they actually were 90 from my point of view.
In Adobe Illustrator you actually have the option like this on both the corners and the cap of the line.
Would this be possible in the next version?

Hi - we have that feature on the wish list (RH-2285 - not available to the public) and I have added your request.
This is not something that is currently on the list for Rhino 7.

Printing some architectural graphics from Rhino 6 at the moment, and the lines show corner artifacts like this:

Would be good to have options how these corners are drawn, like in 2D vector apps.