Stp/Stl export the file writing plug-in failed

Hi there,

it’s a week I have this problem I couldn’t solve reading through the forum.
While attempting to export a step file this message pops up:

some points I have to precise:

  • doesn’t matter the object file;
  • I tried to repair the Rhino installation through the apposite function in the app manager;
  • The necessary plugins are loaded;
  • I will post here in the first comment the systeminfo result.

I really hope you can help me

systeminfo:

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluation, build 2021-11-09
License details: Stand-Alone
Expires on: 2021-12-26

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-23-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 10-20-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.42
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-20-2021
Driver Version: 30.0.14.7242
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino6.rhp “Karamba3DLicense”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\export_STEP.rhp “STEP Export”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\export_STL.rhp “STL Export”
C:\Users\ercom\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Hi -

Does it work when you save to your desktop or a different folder on the C: drive?
-wim

yes, in that case, it works… I suppose it has something to do with the NET framework but I’m not so sure

Hello- is are you writing a second file of the same name, that is, replacing a previous version, with your export?

-Pascal

Hi Pascal, in this case I was replacing an existing file but if I try to make a new file the same error pops up

So, some formats write a temp file - if your target is a synced folder like DropBox or GoogleDrive, then this file needs to be replaced or removed, potentially at the same moment it is being synced - that is my guess as to what is happening - are you saving to a synced folder?

-Pascal

Yes, it’s a folder inside my office NAS that is synced with a folder on my PC… I tried to pause the synchronization but didn’t work

Do you have any suggestion on how to solve this problem?

@tim - do you have an idea? Is this related to writing a temp file, for stl?

-Pascal

A newer build allows writing of the stp temp file to be skipped and works to fix the users problems saving to stp & stl.

-Pascal