STP Export Issue

I can import STP files just fine but if I try to export ANY object in rhino (surface, mesh, polysurf, points, etc) as an STP - the file writing plug-in fails.


Some things I’ve tried:

  • export as IGES or STL (works)
  • remove the STP export plug-in and reinstall and reload plug-in (doesn’t work)
  • export to a local (C:) and network drive (X:) (doesn’t work)
  • tried every STP schema and combination of settings (non work)
  • checked that the STP export and import plug-ins were installed and loaded (Yes to both)

Any thoughts?

Josh @ Kreysler & Associates

Hi Josh -

Just to make sure -when you start with a factory-default Rhino template and create a simple box, can you export that as a stp file?

Please run the Rhino SystemInfo command and copy-paste the result here.

When starting with the factory-default Rhino and creating a simple box, I still cannot export that as an STP. System info below:

Rhino 7 SR33 2023-9-5 (Rhino 7, 7.33.23248.13001, Git hash:master @ 332dda7497b18e9e6f82f118da5cba0c448151a9)
License type: Commercial, build 2023-09-05
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 9-2-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA RTX A3000 Laptop GPU (NVidia) Memory: 6GB, Driver date: 9-23-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.51
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-23-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\export_STEP.rhp “STEP Export”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.33.23248.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

@Joshua_Ermias is this still an issue for you? Can you try a repair of Rhino instead? For this go to Add or Remove programs , choose Modify > Repair.

@Gijs Yes still an issue! I tried doing the Repair through the Windows Program manager as you suggested, but even after doing it and restarting the machine, I still have the issue.

I have also tried uninstalling and reinstalling Rhino.

@Joshua_Ermias really weird… Does this happen in V8 beta for you as well?

@Gijs I just downloaded and installed the V8 beta and tried the export. Same result, didn’t work. In both versions, an empty STP file gets created and a pop-up saying “The file writing plug-in filed”

Is your box a mesh?

in tools>options>plugins> is the step file export loaded?

same issue whether the box is a mesh, open surface, or polysurface

it is not loaded when opening Rhino. When I load the plug-in, I still am not able to do the STP export. It is however enabled and I do get the option in the drop-down menu to export as an STP

can you post your file so I can try here?

I am not using a custom file, I am testing the export with a simple box made by the “Rectangle” command.

2d or 3d? rectangle is a 2d command.

I am making a 2D rectangle with that command.

Neither a 2D rectangle, nor 3D rectangle work - I am just making a 2D rectangle as a quick way to test the export.

Hi Joshua - what happens, exactly? Anything? Do you get the dialog asking you what schema to use, for example? Is there a chance that this is opening behind another window?


In Options > Plug-ins, right click on the STEP Export plug-in and choose the load now option.
Does that work?
Do you get a Yes in the Loaded column?

I assume you are Exporting to your local drive?

I am exporting to a local drive - and loading the plug-in does not work. I had to downgrade my Rhino version to Rhino 7.20 to get the plug-in working, and tested 7.21-7.34 (private) as well as the Rhino 8 Beta. What are your thoughts?