.stp and.igs imports are oriented differently in the world view?


#1

Hi

I hope this makes sense and sorry if i use some of the wrong terminology.

When importing .stp and .igs files they seem to be built in a different world view.

As in I have to gumball alignment every thing 90° twice so that the front is facing the front and the top is facing the top ?

Does that make sense ?

And is there an import setting that would fix this ?

Cheer’s

Glenn


#2

That would be a very good idea, having a flip-axis option on import.

// Rolf


(Wim Dekeyser) #3

How can you be sure which way the z-axis (and x and y) was pointing when that was originally modeled? Also, yes, I used to have to ‘remap’ everything when importing step files from our Pro/E-Creo designers but not so much from NX.

I haven’t looked into it but just remap everything when needed when it comes in. Use the RemapCPlane command for an easy way of doing this.


#4

Depends whether the exporting system is Y-up or Z-up by defaut, or set one or the other way manually.

Another way to think of it is - which view is the logical ‘Top’ or ‘Right’ view for the design/discipline. Depending on Y/Z- up direction, these get flipped, i.e Top is Front, etc.

Indeed. Keyshot allows user to define the Up orientation at import (X, Y or Z), and Fusion allows the default orientation to be defined as Y or Z up.

Yea, I’ve been bitched at by Creo and SW guys on stuff out of Rhino being at the ‘wrong’ orientation, and receive stuff I ‘flip’ in Rhino. On the other hand, the reasonable MCAD guys paying attention to such just roll with it, and leave the original orientation alone so stuff can flow back-and-forth without a repetitive flip/flop game.

@lordarchiebald - for now you might try and ‘negotiate’ a Z-up workflow with others if appropriate and if they are game.


#5

Thanks every one.

So I think for me its going to be that I have to reorient the models that I receive as they come from too many people to ask them to change there settings.

im in the minority on rhino.

Good to know it wasn’t something that I was doing wrong though :wink:

@ec2638 can’t work without flipping. Using a space mouse and it messes with your mind unless flipped :slight_smile:
@wim ill give the remap function a go !!

Cheer’s