Storing list data?

(it’s possible this is a mac grasshopper specific question but even if it doesn’t work on mac, i’d still like to know how it’s supposed to work… (it’s probably not a mac specific question though :wink: )

say i’ve generated a list:

what i’d like to do is unhook Series and still maintain the list… basically, i’d like to ‘Internalise data’ on the Panel but i don’t see an option for that.

what i’ve done so far is to connect the text->Format component to the series then internalize the list there:

.
.

so my question is: What is the proper way to achieve this?

.

another question-

is there a way to create lists manually? just with a panel (or something) and the keyboard?

You can two basic options. The best is to use a Text parameter instead of a Panel, and internalise that. If you really want a panel, use the “Copy Data Only” option from the panel menu while it’s hooked up, then unhook, open up the panel and paste your data back in.

I don’t know if the Panel editor is hooked up on Mac, but if you double click on a panel you can just start typing. If the MultiLine Data menu option on the panel is disabled, each new line will become a new separate text entry.

Text parameters also allow you to specify lists of data (most parameter types do) through the menu, but again I don’t know if this works on the Mac yet.

haha… Text is perfect… and the obvious choice… but somehow i went with the non-obvious component… Format
:confused:

(i don’t want a panel btw… just using it for example in the earlier pics)

thanks David

.

yeah, i’m not quite sure this is working properly right now on mac.

i can get a panel to accept multiple lines if i right-click -> Edit Notes… but it’s not making a list as far as i can gather…

if i edit via double-click, i can’t enter multiple lines even when ‘multiline data’ is enable in the context menu.


maybe @fraguada can have a look on his mac to see if it’s doing what it’s supposed to do?

There are a few things left to implement on the panel (copying and pasting is broken at certain zoom levels MR-2470). You can get ‘Non-Multiline Data’ by right clicking on the panel, and unchecking ‘Multiline Data’:

I’ve checked that the buttons on the Panel Properties dialog also work (on 5C103W), but they give no immediate feedback as to their selection state. I’ve logged this to make it clearer to the user that certain things are selected. MR-2586. Thanks for reporting!

1 Like

oops. i mis-read David’s post saying ‘if multiLine is disabled …
…i was trying it with multiLine enabled.
so yeah, regarding my original question, i’m currently able to make a list manually.

i notice if i context-click -> Edit Notes, i’m able to use the return key to start a new line…
if i’m editing via double clicking the panel, i have to use option-return in order to go to the next line.