Stopping Render freezes Rhino

Rhino freezes if I attempt to stop an ongoing render with a Physically Based material. The problem does not always happen but I have found it more common in two specific circumstances:
A) Attempt to stop the render by clicking the X on the render window.
B) Use a material with displacement

It might be related with the graphics card. In the case of A, sometimes I have to reset the system. Here is my SystemInfo.


Rhino 7 SR18 2022-5-4 (Rhino 7, 7.18.22124.03001, Git hash:master @ b2a1120bcb32e1f6da66a421cd7162a18a9f0cd9)
License type: Educational, build 2022-05-04
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX Vega (AMD) Memory: 8GB, Driver date: 11-26-2021 (M-D-Y). OpenGL Ver: 4.6.14802 Compatibility Profile Context 30.0.14011.2006
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-26-2021
Driver Version: 30.0.14011.2006
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8176 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
D:\PROG_ORIGINAIS\Rhino_Plugins\elefront422\elefront421\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\SpeckleConnectorRhino.rhp “ConnectorRhino7”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.3\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Karamba3D\\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ProRender\\ProRender.Windows.rhp “ProRender”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22124.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Filipe\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Hi Filipe -
Does this also happen when you disable all non-default plug-ins?
If so, can you post a simple 3dm file with which you can reproduce the issue?
Also, when Rhino freezes, please use the instructions on Manually Creating a Memory Dump (DMP File) from an Unresponsive Rhino for Windows [McNeel Wiki] to supply a dump file.

Hi @wim. I haven’t been able to reproduce the issue consistently. So, this has only happened during regular work with all plug-ins loaded. As soon as I get another one of these freezes, I will use the method you suggested to create a dump file and post it here. Thanks

If this is with Rhino Render then the freeze most likely is due to the current pass not being finished yet. You probably need to give it more time to actually stop.

Yes @nathanletwory it is with rhino render (cycles). I usually give it 10-20 min and if it does sort itself I kill rhino process or if the system is also affected I reset.

Happened again today. I have sent the dump file.

Can you post a screenshot of the options dialog for Cycles, please? Tools > Options > Cycles.

Here you have it:

That looks good AFAICT.

Can you try rendering using the CPU and see if it still happens?

I checked the dump you sent: you have a lot of plug-ins still running. From what I can tell the current pass is still not done, but unfortunately from the dump I can’t tell what sort of data you are dealing with. I’m going to guess that with a simple box in an otherwise empty model (and all third-party plug-ins actually disabled: load protected and Rhino restarted) that stopping the render is working just fine. Correct?

If so then it would be useful if you could upload the 3dm file that causes the freeze.

Thank you for having a look @nathanletwory. Like I said a previous post, I haven’t been able to reproduce the issue. I was reviewing a student model not trying to reproduce the issue when the freeze on that dump happened. All I did was to setup a perspective view and run the render with whatever settings the student had in the file. It never went beyond the first pass, it just froze on 0 of 500. After creating the dump file I tried to reproduce the issue, but it didn’t happen again. I will disable all the plugins and try to continue to work and see if it crops up again. I suspect it is an hardware issue with the graphics card…
In any case, I can send you the student file privately.