Stock not visible

Hi all.
I’m newbbie on it, I’ve installed Rhino 6 x64 in windows 8.1, and RhinoCam 2019 succesufully as plugin.
The problem is: Following all steps exactly as decribed in “MILLQuickStartTutorial” I found that never appears on my screen the Stock Box, even if I’ve activate the “Stock Visibility” button.
I’m using a macbook pro, running VMware Fusion Profesional 11.0.2. Iris Intel graphics card OpenGL 3.0 compatible.
Any ideas ?
Thank you. Alberto.

Hi @btxsistemas,

For RhinoCAM support, you might be better off contacting them directly. I’m not sure their support staff hangs out here much.

Also, we don’t recommend running Rhino on VMware - you’ll be better off in the long run installing Windows with Boot Camp.

– Dale

Thank you so much Dale !!!
I was read that about VMware, but I was happy to get all work, until this issue appears. :frowning:

Yeah, I can second what Dale says, RhinoCAM’s display is finicky sometimes and running on VMWare is likely not to work well - also for the simulations.

Edit: shot in the dark - you might try turning off stock transparency and any material simulation and see if that works any better… Both of those may be calling some OpenGL method that VMWare doesn’t like…

Thank you for the idea Helvetosaur, but wont work.

Oh well… You can define a stock though, even if you don’t see it? What happens when you run a simulation?

Oh yeah, if I do all the steps and then run the simulation, it happends like all is fine, but you can’t see anything, paths, material, nothing.

  1. is stock visibility on in both program and simulate tabs?
  2. have you chosen a type of stock from menu that shows up when you click on stock in the RhinoCam window?
  3. MecSoft says not to run in VMware Fusion or Parallels. Bootcamp only. But that may or may not be the problem here. There are a bunch of steps you could’ve missed, beginning with the two above.

I guess the other thing to try would be to set up bootcamp and see if it works there… don’t know how much work that is though, I suppose everything needs to be reinstalled.

1 Like

Max, yes, points 1 and 2 are ok. I follow the tutorial exactly. I’ve tried also a lot of differents ways, and check differents things in configurations, also reintalled twice both Rhino 6 and RhinoCam. Maybe as you say is the VMware issue.

Helvetosaur, for me set up bootcamp is a nighmare, I suppose everything should be installed again, yes.
I never tried bootcamp, because until now, VMware give me a lot of satisfaction.
I use a lot of specific software like, Altera Quartus, Orcad Layout, and many more without any problems, but this is a diferent case. I’ve two computers, and both are MAC’s :frowning:
They’re really great, but in this case are a problem. I’ve tried Rhino 6 for MAC succesufully, but RhinoCam does not exist for mac (in my poor knowledge). Maybe the easier way could be try another cam software…

FYI I gave up on macs and got an HP because of RhinoCam. (also macs still don’t make a laptop with over 32gb ram)

can you post the file? If it works on my machine, that tells us it’s VMware. If it doesn’t, maybe I can see why.

MILLQuickStartTutorial.3dm (114.3 KB)

Why you said: “(also macs still don’t make a laptop with over 32gb ram)” ?? Don’t undrstand what you mean, Do you think running bootcamp neither help ?

I think bootcamp will help.
I do a lot of very curvy carvings and subD work, and I like having more memory for that.

I opened the file and tried it. Stock was set to “none” when I got it. I set it to “Box Stock”. It worked. I then programed a 2 axis profile milling operation, which also worked.

Does this work on your machine?MillQuickStartTutorial.3dm (240.3 KB)

Hi Max.
I’ve just get bootcamp done today, installed W10x64, Rhino, and RhinoCam, now all works perfect !.
So, seems to be that in VMware wont work fine, as all of you mentioned before.
Now I’ve a looong learn curve comming. :slight_smile:
Thank you so much for all of you for your support !!!
Regards & nice week end !!!

1 Like