.stl trouble with RailRevolve


#1

Hi All-

I am making an object to be 3D printed.
No naked edges, closed polysrf. resulting .stl is non manifold. any ideas?

best,

Rev

rail_revolve.3dm (163.5 KB)


(Pascal Golay) #2

Hi Revel - I see that the upper revolved surface and the input curve, presumably has a tiny blob of points right near the middle of the thing - The lower surface has the same ‘feature’, is that intended?

I’m guessing that whole shallw cone should just be made from a single line, in theory, correct? In any case, I think the object is round in plan, and level, so a plain Revolve should get you the object you want, I think…

rail_revolve_PG.3dm (120.3 KB)
@Revel_Woodard try meshing the attached - I replaced the two conical surfaces with ones made from simple lines. (Revolved)

-Pascal


#3

Pascal-

Thank you! The shallow cone is by design, yes, but could certainly be 1
line. How do I do that? FWIW, I made the shallow cone because I thought it
would solve the problem.

I’m still not able to export it. My understanding is that the many long
triangles can be a problem with .stl’s. Is that the issue perhaps?


(Pascal Golay) #4

Hi Revel - is the error message the same? Non-Manifold? Long skinnies are not the preferred triangles I guess, but I would not expect that to be a stopper. Try, in the Mesh command, setting Max edge length - say to 1 or 2. Does that make a difference when exported?

-Pascal


#5

Same error message, yes. just a vague dialog box, no details. tried playing with max edge length to no avail.


(Pascal Golay) #6

Hi Revel - see if the mesh here exports OK for you.

rail_revolve_PG.stl (2.7 MB)

-Pascal


#7

That looks good! Please tell me how you did it so I know.

All the best,

-Rev


(Pascal Golay) #8

Hin Revel - I meshed the object with the following detailed settings (Windows)

and exported the mesh to stl. Max edge length might have been 1 and not 2, but about like that.

-Pascal


#9

That is very interesting. This is not the first time where I have seem something work in windows Rhino but not mac…


(Pascal Golay) #10

Hi Revel - so, with the revised object (simplified conical surfaces) and the mesh settings above, you get a mesh with non-manifold edges and a warning when you export?

-Pascal


#11

Apologies for the late reply-

No, if I simplify the geometry of the curve before revolving it and use the mesh settings described above I get a nice clean manifold object.

Thank you for your help on yet another project!

-rev