STL file will not MESHTONURBS (HELP!)

I am having issues running out of resources when trying to meshtonurbs command in Rhino 5.0. Does anyone have a workaround? I am trying to take a very large complicated STL and shrink it into Polysurfaces. Here is a link…

MeshToNURBS is not going to shrink a model, it will make it bigger. It turns every polygon into a trimmed surface, there is not much reason to use it.

How can I make this file more useable? I can’t do much with it the way it is minus create renderings. It won’t even export into Fuzor or import into Revit. Its currently STL meshes. Do you have any workflows that might help?

Well you can ReduceMesh it to try to knock the polygon count down.Of course the question is, what are you hoping to do with it?

I am trying to use it for presentation into

  1. Revit Model
  2. Fuzor 3d environment

Rhino has a Fuzor direct plug in that works fantastic but it won’t load my model. I am wondering why and it could be due to the mesh count (Assumption). Maybe its not a water tight Polysurface (another assumption).

I used Reduce Mesh which appears to work wonders. But I noticed this these are open meshes so I need to figure out how to make a water tight solid.

Well, V6’ reducemesh does work better than V5s, it may be less likley to split it open. You don’t really need a watertight model just for rendering, though.

yeah I have had great luck with rendering this inside of Rhino with Vray. I just seem to have trouble setting this into a large Landscape/Site File (15 acres) with 6 Buildings (Revit).

Well I don’t know anything about Revit but adding a few million polygons to such a scene as a single object(so instancing doesn’t help) might be problematic. Do you know what the polygon count of the scene is? I think the biggest I ever (accidentally) rendered in Brazil/Neon was about 30 million.

Wow 30 Million? I am not sure how to get the Polygon count. I know the base alone has 23,306 meshes. I have also discovered 11 naked edges on the base. I am trying to fix each naked face. I’ve never had to fix Naked face before so I am kinda of guessing. I’m using the Edge Analysis tool and surface from 3 point with Osnap set to Vertex. Not sure if I am helping or destroying it. There is not a way to either highlight while repairing or move naked edges to a layer while hiding the rest of the mesh is there?


You need to read this:

9 million triangles. Also I downloaded a plug in called Rhino3DPRINT and it fixed my model. Looks to be a good piece of work.