Still having to use TestZBiasFactor Rhino WIP

display
wip
bug
viewport
v6

#1

Hi All,

I have to use TestZBiasFactor every time I get near an object when modeling in Rhino. If I don’t then I see edges “behind” surfaces.

I was hoping this would not be the case with V6 but today discovered I still have to run the command to its lowest setting in order to get a decent display close up.

Before TestZBias

After TestZBias

Is there a setting on my graphics card I should try changing?

Card : Asus TitanX

Thanks,
JRT


(Brian Gillespie) #2

@jeff, @stevebaer weren’t you talking about z biasing in the new code recently? Is there anything to be done here?


(Steve Baer) #3

We can probably improve on this, but in general it is a pretty hard problem to solve for all cases.


#4

Hi @jeff, @stevebaer @brian,

Yea, I’ve talked about z biasing in V05 and the WIP seemed to improve a little, but since using the WIP more consistently I’ve noticed the same problem.

Where does the problem originate from exactly? I ask because I’ve never had this problem in any of the other packages I use (Maya, Mudbox, etc.) and it seems odd that there’s no other work around expect for typing in a command every time I open Rhino

Thanks,

JRT


(Wim Dekeyser) #5

Back in the old days I had that in my start-up commands…
(but now I only have it on my middle mouse pop-up anymore but it’s really a long time since I’ve used it).


#6

Thanks @WimT

I tried adding it to my startup scripts but nothing happened. When I checked by typing the z bias command manually I found it never executed.

If you don’t mind could you tell me what I’m doing wrong (see below)

This is the startup script that loads:
!testzbiasfactor _.125 _Enter

This whole thing seems bizarre. Viewing an object without seeing through a surface seems like it shouldn’t happen to anybody barring totally unsupported graphic cards.

Thanks again,
JRT


(Steve Baer) #7

It has to do with resolution of the Z-buffer in the case that you posted screenshots of. Because the geometry is very large compared to what you are zoomed in on, the near and far clipping planes of the camera are much further apart than they really need to be. You can probably see this if you run ShowCamera on that viewport. This can probably be improved upon in several ways (one of which is improved near far viewport calculations) and may end up getting fixed in the near future by using a different algorithm for biasing in our new shaded mesh OpenGL shader.


#8

Thanks @stevebaer,

That make sense, thanks for explaining it definitely helps.

JRT


(Wim Dekeyser) #9

Is that what you put in the Rhino Options > General > Command Lists?
This seems to work:


#10

That was it, I had it linking to a Rhino script file instead of just running the command every time Rhino starts.

Many Thanks.