STEP files from won't open in Rhino

Head scratcher. I’ve downloaded step files of fasteners from as STEP AP214 files. Either by double-clicking the file to open in Rhino directly, or the long way round by opening Rhino and ‘import’, or else ‘open’, none of the models appear. Actually, going through ‘import’ or ‘open’, the command stays stuck at the ‘Open’ button. File properties (in Windows Explorer) don’t show any read-only problem. It may well be a problem with the files or the site though, as other step files will open ok. Unfortunately I can’t find these particular UNC csk screws I’m trying to use, online anywhere else. I did try downloading from two different parts suppliers on the site though. So may be it’s a site problem (?). Or am I missing a trick?

(None of the following should matter, but for diagnostic elimination: STEP import is enabled in Rhino. My Rhino 6 is latest update. W10 did just do some kind of massive update to build 19041 a few hours ago - but all else seems ok when working in Rhino since that.)

do you have the links of the fasteners you want?

See if you have better luck - here’s a couple (Bossard and Fabory versions of the same fastener):


Hi Ian - can you post or send to an example that fails?


Hi Pascal. Yes. Try these. I’d be interested to see if they work for you.

BN 48739 3465563 slot flat head countersunk machine screw 0.25x0.75.stp (25.0 KB) Slotted Flat Countersunk Head Machine
Screw ASME B18.6.3 1_4X3_4 U51110.025.0075.stp|attachment
(20.2 KB)

I tried one of the links with the first item as STEPA214 and no problems:

I don’t know if this could help somehow. it doesn’t have the thread.
this one is from McMaster:

both step files you just posted opens without problem:

1 Like

Hmm. So its’s some kind of problem at my end. And yet, for example I downloaded NSK bearings as step files a few days ago from, they load fine.


Thanks Diego – I hadn’t thought of McMaster Carr, and the download from there works absolutely fine.

There’s something fickle about the step files from partcommunity it would seem.

Anyway, you’ve solved my immediate problem!

1 Like