Startup Errors

Hi Developers,
Please urgently help me, I am working and my Rhino is getting progressivly problematic.

I recently updated to the latest version of Rhino 7 and have been encountering several issues that I’m hoping to get some assistance with.

Firstly, upon starting a new file in Rhino, I am greeted with a Python ImportException See screenshot stating that the rhinoscript.application module cannot be found. I am running the software on Windows 11. The error screenshot is attached for reference.

I suspect this could be a plugin conflict as I tend to keep a lot of them installed.I have unistalled several incl GH python because accordding to the git hub its no longer supported.

My Rhino Viewport Tabs Panel was locked but after a restart it worked. Unfortunatally its completly missing now. Note Im not sure if thats related to Varq which I have also upgraded. Anyway please see screenshots. Let me know if I should run a system scan or anything?



Any help would be great. Its also interfering with my tech drawings. Line weights seems different.

There are a bunch of different issues in this post, which means the replies are likely to get confusing, or some parts of the question will be lost. In general, I recommend starting separate threads with each problem in a new topic.

But here we go…

  1. Viewport Tabs. You can get them back in Tools > Options > Appearance > Viewport Tabs at Start

  2. It looks like you have something called “Fractal_v1” installed; find it and delete it and the second Grasshopper breakpoint error should go away.

  3. Unrecognized objects happens when you try to open a Grasshopper file but don’t have the appropriate assemblies installed. If you click Download and Install, Rhino should find them from the pacakage manager. If not, you’ll need to go looking for them - perhaps on https://www.food4rhino.com

I have successfully resolved most issues using ChatGPT. The majority of conflicts were resolved after I uninstalled Python for Grasshopper and deleted my grasshopper_gui.xml file in AppData\Roaming. Additionally, I ran a Rhino fix via the Rhino reinstallation.

  1. Viewport Tabs: The initial problem was resolved by itself after a hard reboot.
  2. “Breakpoint Error in Grasshopper”: This issue persisted until I performed a reinstall and fix through the Rhino installer. I also removed Tree 8, Grasshopper Python, and Tree Sloth.
  3. Unrecognized Objects: The attempt to download and install from Food4Rhino was unsuccessful. I suspect these issues were ultimately due to a conflict with IronPython, possibly because of the GH Python version I installed. I wrote a script to list all my GH and Rhino plugins and checked most of them, which helped reduce major errors.

The only remaining issue is the “Tree 8 Missing Report”. Despite extensive searching, I’ve been unable to locate the plugin on my system. I downloaded and installed it from the old GH website, but this led to major conflicts.

While I can manage with the error report, I would appreciate any suggestions on how to locate the script or plugin that requires Tree 8, so I can remove it. I’m puzzled as to why this particular update caused so many conflicts for me and would be interested to hear if anyone else has experienced similar issues.

1 Like

I don’t see that in your original report. Can you please send a screenshot of whatever error you’re seeing related to Tree 8?

Also, if you’re willing to share, I’d love to see your ChatGPT transcript.

1 Like

I have this problem for some time also, Could you tell me how can I uninstall GhPython from Rhino? it doesn’t appear in Plugin manager

From the above screenshot, it looks like the issue was with parakeet.ghpy and not with GhPython itself.

I would not recommend removing any gha that ships with Rhino (python in this case).

HI Brian
Thanks for this.
Please see attached my tree8 and now a new varq error.
I dont think that I am 100 % out the woods yet.
Just a note. I did not unistall the GH.python that ships with Rhino I deleted the one I downloaded from foodforrhino GH_CPYTHON(by MahmoudAbdelRahman)
Can I privatly upload my chat GPT convo soemwhere?


Screenshot 2023-12-11 103729

Yes, you can DM me by clicking my profile picture above, then clicking Message.

The error you are getting with Tree8 isn’t actually an error. You’re opening a Grasshopper file that contains one or more components in the Tree8 assembly. I presume you didn’t create this grasshopper file? Can you please attach the one you’re opening here?

As for VisualARQ - are you using it? If so, click No to the question above. It looks like you may need to uninstall or repair the installation for VisualARQ

HI Brian

Thank you for your input. Regarding the “Tree8” error, it presents itself each time I launch Rhino.

After disabling VisualARQ yesterday, the previous issues I was experiencing ceased. However, upon uninstalling and then reinstalling VisualARQ, I’ve encountered a new problem: VisualARQ no longer loads at all, which is quite frustrating.

At this stage I think I might need to do a complete clean reinstall of rhino 7.

Any further assistance with this matter would be greatly appreciated.