SR11: selection flashes between Isocurves and custom visibility

Just installed SR11 due to a different error I had.

First thing I noticed is that when I select objects the yellow selection flashed between the standard visibility (Isocurves and 2px thick surface edges) and my custom visibility (no Isocurves and all 1px thickness). The flashing happens only when I rotate or pan the camera. It even stays in that state when I stop moving. See images:

Hmmm - what I see is that on selection, the display mode specific settings go out the window and I see the full wireframe highlighted.


I think this is how it is designed to work. I see from your previous SystemInfo report that your drivers are from March of this year - it might be worth going to the NVidia website and getting whatever their latest driver is for your card.


I agree, that’s how it should be. I installed the latest display driver but it didn’t help.

I don’t want to sound crazy but the flickering is only happening on SOME objects in my file. Specifically, those I have been working on since I updated yesterday. And, it’s also only happening if I zoomed in on the objects. Once I zoom out far enough the flickering stops.

I have copied those objects into a new file and it stopped flickering. Weird?

Correction. It doesn’t flicker any more but it does switch between those two selection “modes” once I zoom in enough so that the object is larger than the viewport - roughly.

Hi Oliver - I guess the best is to post the file or send to, and we can try to sort out what’s going on.


Hi Pascal,

doesn’t matter what file, the flickering persists. When I’m far away from the object the selection shows the full wirefram. When I zoom in it starts flickering.

Hmmm. But some objects and not others - is that still true? Is there any obvious difference, like object type (Meshes, surfaces, curves etc) that corresponds to the behavior?


It’s true for all NURBS objects. Closed breps or surfaces, all of them.

Meshes don’t seem to have a difference between selection and non-selection except for the color, and that seems to work.

It’s flickering in in shaded and ghosted view mode, with or without textures. It’s not flickering in rendered view.

Hi Oliver - thanks - can you also please run SystemInfo in Rhino and paste the results here?


Interesting additional observation: if i reduce the wire thickness with testwirethicknessscale to, for example, 0.5, the flickering is doing the same thing to all wires - flickering between 0.5 and 1.0 wire thickness.

Rhino 6 SR11 2018-11-27 (Rhino 6, 6.11.18331.19171, Git hash:master @ 96781d86a3016c6680f1bf39f87ce37364ec2323)
Licence type: Commercial, build 2018-11-27
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: TELAVIV

Quadro P500/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 411.95)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-8-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Geometry Gym\Rhino3d\ggRhinoIFC.rhp “ggRhinoIFC”
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.11.18331.19171
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Oliver - thanks - this is something of a shot in the dark but just to eliminate a possibility, can you please disable VRay in Options > PlugIns page and then restart Rhino and see if that makes any difference?


Hi Pascal,

I tried that but it didn’t change anything!

I copied a few of the objects from this file into a new file and didn’t have the problem afterwards. Maybe the file is weird or too big (it’s not really big but full of blocks). Only when I copied more and more objects did it start flickering again. Not exactly sure if it’s related to one specific object in my file or the size, or a material.

Hi Oliver - thanks for the details - I’m beginning to suspect an object or objects - did you copy blocks into the new file? Can you try deleteing half of the objects and see if the problem goes away - if not Undo and delete the other half… if so, repeat by halves until you can isolate the object(s). Should be fairly fast… Or just send us the file ( and see if we can reproduce it…


I’m afraid it happens in other files as well, even those I made before SR11. It didn’t matter which objects I deleted, as soon as there were more than a few I could see it happening.