Square artifacts when rendered in Perspective Artic Render mode

Anytime any perspective render done in ARTIC RENDER mode I get these square artifacts.
What is the remedy???

Hello- please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

Rhino 7 SR29 2023-4-17 (Rhino 7, 7.29.23107.03001, Git hash:master @ 5f05ef3a2eea3d910c4c2fb79ccc75b413d33ca7)
License type: Commercial, build 2023-04-17
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 3-9-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 528.79
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-9-2023
Driver Version: 31.0.15.2879
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.29.23107.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello- System Info looks reasonable to me - is your image above from the viewport or from printing?

-Pascal

Printing to image file as well as when printing to PDF… same problem. Only happens in Artic Render mode and that is the number one mode I use for renders as system chokes in raytraceing.

@DavidEranen - is this something you can help with?

@TavVal - the scene you show should not give raytracing any trouble - does it not work here?
Can you print correctly from a Rendered mode viewport?

-Pascal

Everytime I try raytraceing the system slows to a crawl and in under a minuate Rhino becomes unresponsive.

Hi a @TavVal i assume your viewcapture pixel size is bigger than your main monitors resolution?

I had similar artefacts appear on a dual-monitor setup with big-ish pixel sizes for the capture.

Try unplugging one monitor or setting the capture size to something less than your monitors resokution to see if that helps. What i typically do i having a capture size of 1080p and using the scale option i can get my desired final pixel resolution.

Let me know if that helps or the issue is something else

So I have been trying different things and this is what I found:

  1. When the “PRINT TO EXTENTS” option is activated on an ARTIC VIEW render to file or print, it causes this square rendering atifact. As long as I set 1:1 and then SET VIEW it works fine.

So it seems specific to useing the PRINT TO EXTENTS in ARTIC RENDER MODE when printing to image.

Hi @TavVal,

I’m not able to reproduce this issue. Can you send me the model so that I can try to do exactly what you are doing?

Thanks,
-David