Splotchy Mesh Behavior

Hi all, it’s been a long time … I just downloaded this banquette from the Sketchup 3d Warehouse and am trying to get rid of the splotchy texture on the curving parts. I tried exploding the block, and setting the Display Color to By Layer but neither seems to help. I tried applying a specific texture to it (grey) but that doesn’t make a difference either. Any ideas would be appreciated.

Splotchy Mesh.3dm (13.1 MB)

The mesh has many non-manifold internal faces. So there is self shading going on and normals that conflict. Running the check command on it results in this:

General information about this mesh:

Mesh has 249 degenerate faces.
Mesh has 557 non manifold edges.
Mesh has 43 duplicate faces.
Skipping face direction check because of positive non manifold edge count.
Mesh has 8507 pairs of faces that intersect each other.
This can cause problems if you’re doing mesh boolean operations with it.

Mesh has 126 naked edges. Naked edges can cause problems if the ultimate goal is STL output.
Mesh has 1599 faces where the face normal differs substantially from the vertex normals.
These normals can cause problems if the ultimate goal is for rendering or boolean purposes.

Hi Scott:) Would you say this is unfixable? That is, unfixable without spending hours repairing it?

It is complicated, but what was the original entry in the 3d warehouse. Perhaps there are other formats?

In addition to Sketchup, there is GLB and Collada.

Give the Collada a try. If you get the the link to the 3dwarehouse resource I can also do some testing.

Here’s the link to it, Scott.


As far as Collada is concerned that’s not supported, right?

Looking closer to that model in Sketchup you can see that the segments of the couch share vertexes, overlap in odd ways and have many internal faces between each segment. But, even the segments are ovelapped.

I imported this with these options, no joins, no textures:


It works much better:

But it is still a nightmare mesh in that there are many internal faces hiding within the volume. Cleaning out the 500 or so internal faces would help a little.

1 Like

The problem with Sketchup that your best case is to import as a mesh, it is still going to be a nightmare. going with untrimmed planes makes it even worse, so my suggestion is to use what @scott suggested, then use Rhino built in tools to repair it. I always run QuadRemesh but also I think in this case Shrinkwrapping can be helpful too.

1 Like

Thank you all. These suggestions are great and the result is well worth it. Thank you, again.

1 Like