Split Brep bug, V6 SR34

Brep_split_issue.gh (15.7 KB)

Example attached. I’ve tried a few experiments for workarounds, but as a general script it should be robust enough to not need a user to go back a plug in a workaround on some cases.

I’ve been using spit brep throughout the larger script without any issues, up to this single instance.
The cutting brep does find a polyline intersection, but fails to cut even using that line.

The cutting brep has a tiny dogleg kink in the center, but I’ve tested it with a more spread out three panel solution, and the result was merely the polyline intersection also failed.


I’ve had a quick look, and it doesn’t look like even the first cut is working as expected, as in the graphic view you can see some darker region on the cut brep, suggesting a ‘doubling up’ of the brep. If you find the boundary of the cut brep and re-construct the brep, then the area is smaller than that of the original cut brep.

I’ve tried rebuilding the original brep using the same method of finding the edges (haven’t done a sense check on how well it matches the original) but this seems to make everything work down stream.

How was that original brep generated?

Original brep was made by ruled surface between the girders at widest point, then shifted up to deck level and cut by girders to the one shown in the example.

I applied your trick of deconstructing and reconstructing the ruled surface. The result is a teeny area change, and feeding the reconstructed brep in to the scrip means all downstream parts work. The ruled surface must have been folded back on it self somewhere.