Splash screen... rhino taking 5 mins to open because of splash screen thing

That sounds more like a computer problem to me than a Rhino problem. Having other apps open shouldn’t affect Rhino’s startup time unless those are running your computer out of resources and slowing everything down.

@robin - something else comes to mind now, I seem to recall something like this in the distant past -

Do you have any files on a network drive? The splash screen tries to list your most recently used files and I seem to recall that someone had long startup times because the splash screen wasn’t able to access the network storage quickly enough or the original files has been deleted or something like that. Just a shot in the dark.

That’s sounds like you don’t work much with Rhino and other engineering tools in combination.

3DEXPERIENCE takes up 15 gb ram easy.
ANSYS too.

Simply proves my point. Those apps are eating all your resources - not Rhino’s fault.

flys open in safe mode… less than 3 secs I would say. really not sure what plugins to disable or how to check video thing to be honest.

If there was no splash the time it takes will be reduced.
Stop blindly defending this please @Helvetosaur.

OK… If you go to Options>Plug-ins, and in the pull-down menu you choose “Plug-ins that do not ship with Rhino”, do you have anything in there? If so, try disabling those first (uncheck the “enabled” box) and then close and re-start Rhino in normal mode. If that doesn’t help, or if there aren’t any external plug-ins in the list, then it might still be a video driver thing - as opening in safe mode also cuts the OpenGL in Rhino V5 IIRC…

You might want to start another thread then as the OP’s problem clearly has nothing to do with your few seconds difference.

1 Like

And what are you going to work on without plugins? If that is the slowdown then again what has to be implemented is dynamic assembly loading. Meaning, the plugins will load only after a command coming from a specific plugin has been run.

1 Like

i sometimes have to open stuff from others in my customer list. one recently was I think linked to a network drive but not sure. I did think if I saved another x6 files as samples maybe it would only load them as the last ones but that did nt work. maybe I need to delete something or start fresh somehow? i feel unable to figure this out? think a total uninstal then load rhino as new is the answer? its slowing beyond practical.

I think that is up to the plug-in creator - you might want to ask them. I know for a fact that a lot of Rhino native plug-ins (such as import/export modules etc.) do not load until you call a command that needs them - so it’s possible at least in certain cases.

is there anyway of flushing out the old files its trying to find you think? thanks.

There is a registry entry, but I do not know of a way to do this from inside Rhino.

HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Recent File List

You can delete all of the entries (except maybe the first) and restart Rhino - that will clear the list.

massive thanks for helping me. I am not sure how your reaching that window is it on c drive cos I cant find anything like that its not within rhino its self then as you say? I am at a very low level of understanding pc wise… My cad great though ! sadly not much help when there a problem though…

At the Windows Start button, type regedit.exe That should open the registry editor (answer yes to the security prompt). In the tree view on the left, you can navigate along the path posted above:
HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Recent File List
Once you get there, in the right hand panel, you should see the list of recent files. Simply select them all or one-by one and right click, choose Delete. You will get a warning that editing the registry might be risky, but there is no danger in this case. Do not touch anything else though.

Note also that this is only valid for V5. V6 has a button in Options>Files that says “Clear recent files list”. Much easier.

hiay… deleted all but the 1st one and still the same… sadly! wonder if its the driver for graphics card now as no updates available for it anymore. Maybe after rhino updates just will not work. Graphics card is old but fast enough but no driver available to update it. I ve idea how to make sure my mother board will work with a new card looking at around a £450

I use freeform software so need to buy one of these but not sure if drivers are available for the windows seven that I run. Maybe i have to buy whole new system?
I just spent 30k on a wax printer (projet mjp 2500w) plus tax bill and vat so feeling broke and over whelmed with tech issues!

OK, I’m running out of ideas here… V5 wasn’t all that problematic with older graphics cards/drivers (V6 is more critical) so I’m not sure if the hangup is caused by that. The fact that it starts fast in safe mode is a good clue that something loading/running afterwards is causing the problem, but I don’t know what else to test… @pascal, any other things you can think of?

My only thought of the moment, and I am not staking my reputation on this, is that there is some hangup getting the feeds needed to update the splash ‘news’ stuff…

@robin - how’s your internet connection, in general?


@robin can you try the -stopwatch thing again? Note in the post above where it was suggested there was a typo - what you need to add to the target is -stopwatch, not -stopwatcg

The target path in the desktop shortcut should look like this
"C:\Program Files\Rhinoceros 5 (64-bit)\System\Rhino.exe" -stopwatch

I just looked into the v5 rhino folder and theres a v4 exe file there not v5? i guess thats weird right? When i installed it asked me for the previous rhino version lic code for what ever reason. Think this is the route of the troubles? can i just rename it or will that ruin everything? thanks,