Splash screen... rhino taking 5 mins to open because of splash screen thing

Hello - if you do not use that shortcut, can you see if the splash tells you what it is hanging up on?

-Pascal

after the delay of few mins rhino opens and splash screen appears for only around 2 or three secs only thing in that time I can see is loading view ports and fly’s open. Its the point that nothing happens for ages then opens. I recently changed my broad band provider could it be a communication thing with license or something? Doesn’t explain why when skip splash screen it opens in around five seconds! I think what triggered it was I opened a file couple days ago and i got that palette thing where they are spread all over the screen and view ports go tiny… had to arrange all the palettes again and save as template file again. I ve used rhino for years and years.

@pascal there is a -stopwatch command line arg that may help diagnose where time is being spent

There are some feeds that load on the splash so that is not out of the question either. Steve suggested trying the -stopwatcg switch - if you add that to a normal startup icon like so:

then open Rhino using that shortcut, then hit F2 once Rhino is up, you can copy paste the pile of info back here and maybe we can see what the hangup is.

-Pascal

Hiya thanks pascal… its 5.30 am here and i cant sleep! i ve done the stopwatcg switch adding it to the shortcut line then opened it… then F2 key. below is what it says :

Loading Rhino Render, version 1.50, May 22 2017, 10:01:30
Command: _CommandHistory

I am totally rubbish at understanding this stuff so no idea if this information helps at all? thanks.

Thought i d add that when added the stopwatcg to the start up no splash screen appeared or if it did it was so fast you cant see it…

If you read further the thread that @Dancergraham suggested you will find this answer:

IMO the best/only acceptable solution for Rhino Splash.
However since McNeel do not want to accept the default splash is bad and to a big extend too much slowing down startup. They do not want to provide some option to disable it. So you have to delete or rename the dll after every update of Rhino.

2 Likes

i just tried that put into waste bin but then opening rhino and the same delay happened. i did nt empty the basket though. I wondering if I uninstall rhino v5 and start from new if that would fix it? I d need to set up template files again though which feels me fear as lots to set up with palletes and all that unless you can save a template file and import it but maybe that files part of the problem?

@pascal, @stevebaer - V5, not V6…

That’s because it isn’t true - at least not normally…

On my 5 year old desktop here:
V5 with splash screen + stopwatch - 4.25 seconds
V5 nosplash + stopwatch - 3.75 seconds.

I don’t call 1/2 second an immense slowdown.

Edit - sorry I had inverted the times when typing - the nosplash was around 0.5 seconds faster

It’s quite possible that the splash screen is not the cause of your slowdown. Does it have the same delay if you open Rhino in SafeMode? (Start>All Programs>Rhinoceros 5>Rhinoceros 5 (64 bit) in same mode). If it opens fast in safe mode, it may be a plug-in loading that is the problem - or maybe a video thing.

1 Like

Where is your measurement for RhinoSplash.dll deleted?

Why, you think it runs faster than with “/nosplash”?

because it does

Update: My thinking is, one assembly less to load into memory, a few less parameters/variables/globals to check/populate in memory when the dll is missing.

Not really. Disabling it (I just renamed the dll extension to .stop) brought the time to ~3.7 seconds. Note the licensing screen still comes up after disabling the .dll, but not the rest…

image

With -nosplash, even with the .dll active, there is no license screen.

Just remember, Rhino needs a certain time to start up - it’s not instantaneous and it depends on what plug-ins are loading. The splash screen is shown during the startup sequence, but Rhino is still doing other stuff to start u p in the background. Plugins can drastically slow down Rhino’s loading, for example if I have both RhinoCAM and V-Ray enabled at startup, my startup time before Rhino is ready can go up to 30-45 seconds…

The license screen appears everytime for me even with the splash screen on.

As for the measurement, try clicking on this (primitive) splash right after it appears with the DLL disabled.

Then compare it with clicking the X on the normal splash.

I’m only using the stopwatch thing which automatically spits out the time when Rhino is ready. Clicking on boxes introduces some variability. Besides, I’m not interested in differences of a second or so - that’s ridiculous. The OP complained of 5 minute startup times - so we’re not talking about a couple of seconds.

Well for you maybe, for many people including me, any optimization being it a second or two matters.

Clarification. Running multiple heavy applications along with Rhino makes this second more like 10+

That sounds more like a computer problem to me than a Rhino problem. Having other apps open shouldn’t affect Rhino’s startup time unless those are running your computer out of resources and slowing everything down.

@robin - something else comes to mind now, I seem to recall something like this in the distant past -

Do you have any files on a network drive? The splash screen tries to list your most recently used files and I seem to recall that someone had long startup times because the splash screen wasn’t able to access the network storage quickly enough or the original files has been deleted or something like that. Just a shot in the dark.

That’s sounds like you don’t work much with Rhino and other engineering tools in combination.

3DEXPERIENCE takes up 15 gb ram easy.
ANSYS too.

Simply proves my point. Those apps are eating all your resources - not Rhino’s fault.

flys open in safe mode… less than 3 secs I would say. really not sure what plugins to disable or how to check video thing to be honest.