Splash screen icons

… “missing”…


You’re referring to the thumbnail preview of the file in the Splash screen right? This is generated by an associated version of Quick Look and sometimes I think the number of versions of Rhino on the Mac can cause this to happen. If that is what you’re asking about, try this… make a new file with some object and save the file. Then in the folder where it was saved, right click it and choose Quick Look, this should be the viewport shown when you saved the file. Then restart your Mac, all the 3dms should show the thumbnail view in Finder and the Rhino 7 splash now.


Thank you! I’ll try that :+1:


Sadly that didn’t work. I still have the Rhino icon in the thumbnail…

SystemReport iMac Pro.txt (6.4 KB)


There are a number of threads on the forum where this has been reported over the years. Some users had to restart their Mac more than once for quick look to show the thumbnails again.

Yes, I remember seeing this before, but didn’t find any thread in my search… Selecting the file with Quick Look in Finder displays the Rhino logo - and restarting a couple of times haven’t helped.


If you’re still experiencing this issue, you might try clearing your QuickLook cache.

I scanned these instructions and they still appear to be up-to-date:

Yes, still the same problem… I’ll try clearing the QuickLook cache.


No, that didn’t work, unfortunately. I restarted the computer also, but no… Same problem on both my iMac and MacBook.



Thanks for trying a cache reset. Sorry to hear it didn’t work.

I presume we’re looking at Recent models here - I can’t tell from your screen-capture whether you’re in the Recent or Templates tab. I’m going to presume you have the same problem in both tabs unless you tell me otherwise.

What happens when you navigate to these files in Finder, select them with a left-mouse-click and press space?

Is it just Rhino 3dm files? Do you get QuickLook thumbnails for other file types?

What happens if you disable your Twinmotion plugin, then restart Rhino?

What happens if you disable your Bella plugin, then restart Rhino?



Same thing as in the splash screen - I see the Rhino logo.

Yes, only Rhino files - all other files (for instance pages, pdf and other) show the thumbnail normally.

Hmmm, actually… I have Shapr3d on both my computers - and Shapr files also display the Shapr icon and not the correct thumbnail picture. Shapr has also taken over as the default application for opening STEP and DWG files - and I can’t change that behaviour even if I try to change it in Finder (“open with…”). Could that have something to do with the thumbnail issue as well?


Perhaps. Something smells really wrong with QuickLook still. It’s odd - and telling - that you have the same problem on both Macs. This is not surprising really, and sometime instructive, as we all tend to configure two machines we own in similar ways…it’s just figuring out what we are doing that usually proves harder.

I’d try disabling plugins first too.

How many installations of Rhino do you currently have on these machines? Run TestFindAllRhinoApps to find out. The reason I ask is that QuickLook is a macOS feature that loads a plugin - for macOS - that we author and ship with Rhino for Mac. When app bundles - of any app - get installed, macOS checks to see if they have a QuickLook plugin that can handle those file types and load them. I’ve seen problems before where multiple conflicting versions of the QuickLook plugin are attempting to get loaded and failing, so macOS just bails and presents the default icon.

Hmm… I seem to have two Rhino 7 on my iMac:


…and this is my MacBook:


It seems unlikely older versions of Rhino are the problem here, but I cannot be certain. On your iMac, you might zip the old ones up, move the zip to your Desktop, restart macOS and see. It would be an easy test to run…but I kinda doubt that is the problem. We did make changes to the QuickLook plugin between Rhino 5 and Rhino 6; but not 6 and 7.

Nope, sorry - that didn’t work either.


Sorry, I’m out of ideas on this one.

Hi @Philip @dan
I had the same issue and it appeared that the attached file was missing from the Macintosh HD/Library/LaunchAgents. Now it works again. I found the content of this file on this website
com.apple…quicklook.plist.zip (916 Bytes)

Odd and interesting. I do not have any problems with QuickLook previews and I do not have that file in:

  • /Library/LaunchAgents
  • /Library/LaunchDaemons

I do not understand why you would need it there. My understanding is /Library/LaunchAgents is for third-party launch tasks; not Apple ones. I could be wrong.

I took a closer look at the file; which, incidentally, contains an extra . in the reverse-dns notation. The file should be titled: com.apple.quicklook.plist…but that’s beside the point.

This launch agent task simply turns around and launches macOS’s system QuickLook process:


I don’t see the harm in that…but if QuickLook is not loaded, I don’t see how other application’s QuickLook previews are working, but not Rhino’s. I still suspect something else system-specific is amiss.